Beta App not giving directions but shows route

4 year old Samsung J3 “offline” shows route, and follows route.
The Beta App provided one spoken direction at start - then no turn guidance or spoken directions. Main symptom is no turn guidance top left of screen. The app is showing progress along route.
So the GPS is allowed and working.
The app is not frozen or hung up. No other errors.

2 year old Samsung A12 functions perfectly with Beta App (testing it on 2 phones).
Turn guidance (top left of screen) plus spoken directions working.
This phone is connected to cell network, the other one is not (may be a clue).

Sorry if this has come up before, could not find it in searching forum posts.
The older Samsung is running Android 9 with simple location permission “on or off”. From what I have read, “on” includes background and is the same as “all the time” (that setting choice began with Android 10).
I have tried Kurviger on that phone a few times and did get turn by turn and voice but it stops giving that guidance but does GPS track along the route.

I read this I can't hear any voice output / turn instructions [Kurviger Knowledgebase] and could not find anything out of place on the older phone.

1 Like

Could you clarify this for me. What do you mean with no turn guidance? Is there really no turn guidance, or is it not updating?

Was this a one-time issue, or did it happen multiple times / all the time?

Is this happening when you are using the simulation?

If this issue persists, maybe you can provide a screenshot or a screen recording that shows the problem?

Background permission is only relevant if you lock the screen or have the app in the background. If you can see the app, this should not matter.

Yesterday the route began giving the first turn guidance (top left screen) with spoken directions.

The next turn there was no guidance (top left screen just had forward arrow, like not updating) and nothing spoken. I almost missed the turn, but could see the route on screen and the GPS was moving me along the route. Just no guidance at all after the first turn. Phone display on, mounted on handlebars.

Was this a one-time issue, or did it happen multiple times / all the time?

Multiple times. It started out OK, then multiple turns not displayed, no guidance.

I just ran the same route in simulation and it was great. No problems.

Here in simulation that same turn is displayed and spoken directions working normally.

My newer phone (connected to cell network) functions well with Kurviger and I like the app. I was testing it on the older phone (not activated on cell network) as I learn the features and functioning of the app.
I am trying to quit Google Maps and quit Garmin.

This sounds like the offroute arrow, the arrow points towards the next unvisited waypoint. I would recommend to give this another try, it should work without a network connection as well.

Created a new route. Short and simple.


I set the start point down the street. Start navigation and get spoken directions to turn left (from my driveway) on my street. All good.

As I travel down my street and approach first turn, there are no spoken directions or visual turn guidance (top left of screen). The movement along route with GPS was accurate, just no guidance.

I just ran this same GPX route in simulation and there was no guidance or spoken directions until the end “in 1,000 feet arrive at destination”. This means that the device audio was functioning but during the travel along the route there was a failure to provide turn directions or spoken guidance.

My newer phone (on cellular network, online) provided all guidance and spoken directions a couple days ago on longer route - however I tested that phone yesterday on this same GPX file and it failed to give any guidance or spoken directions. It behaved exactly like these screenshots - a straight arrow rather than “turn”.

You have placed over 20 shaping points on 3 miles and placed them on intersections. Probably you used the route import from a GPX track.

I would recommend not to place waypoints close to intersections and not to place too many of them.

I would expect that the same route without shaping points should work fine, could you give this a try?

Using the default Kurviger Web Site settings, the exported GPX file has additional waypoints created by the program. Some of the waypoints (shaping points) added by the Kurviger are at intersections.

As a long time BaseCamp user (hater) I have learned to place shaping points before and after an intersection, and maybe one along that road before the next intersection. This helps to force the route to stay as you created it.

I created this test route again today, leaving from my house.

I don’t know if the quantity of waypoints is stopping guidance during navigation or not.
My initial impression was that Kurviger default is to add waypoints, to force a route not to recalculate on a Nav device so the route remains intact.

I saw it as a good feature.

Have a look at the documentation Route Transfer (Import, Export)

If your nav-device is the Kurviger-App, I would use either “cloud” or *.kurviger file format, instead of *.gpx.

*.kurviger is the native file format of Kurviger and contains all the setting you have used when creating the route. So a route created on the web site will be identical on the Kurviger navigation app.

If a waypoint is to close to an intersection, that waypoint might prevent the turn instruction.
If you stay in the Kurviger universe I would recommend ~10 waypoints per 100km.
Or ~15 waypoints per 100 miles, for the guys with the alternative measuring system :stuck_out_tongue_winking_eye:

When placing waypoints, stay away from intersections!
Best is to place your waypoints in the middle of the road you want to ride.

1 Like

OK, when I first tried the app about 10 days ago I saved in that format and it worked

Later when I tried the app I could not find how to save as a Kurviger file.

Today I see this - and it may be something with English translation but I thought it said “Kurviger” last week on the options.

I do understand that Kurviger is German word for Curvy (Twisty road).

But when I saw a file extension *.curvy I did not recognize that it was a default Kurviger file.

Today I did the export

And the result was a “.kurviger” file. (not Curvy).

I am very patient, and also familiar with tech so this doesn’t bother me now that I know what it is.
As a translation for English speaking people, I would recommend not suggesting “Curvy” as a file type.

Kurviger has become well known, and obviously someone got to your web site in order to be doing any of this. May as well keep it consistent and just call the file type what it is.
That is what the exported file will result as *.kurviger.

Thanks for the link, I see that now.
By default Kurviger will add waypoints (shaping points) to a GPX file, so we are relying on the customer to change the default setting for export to GPX if they happen to try to navigate that file with Kurviger app.

It may be helpful to have some short guidance on the “save as” export .
.Kurviger (best for export to Kurviger app navigation)
.GPX (choose “few” additional waypoints if using Kurviger app navigation)


Your screenshots are a little bit strange …
If I switch to English my export panel looks:

Kurviger is not named Curvy and the index line looks different. As I said: strange!

And if one is using the Kurviger App for navigation he should use .kurviger files exclusively - period! The .gpx format is for Garmin-/TomTom-/whatever-Users. And for these devices additional waypoints are advantageous.


I am English language Australian User but when I first load I always get German and I get the word Curvy

When I change to English or any other language from German I currently get an error

This site can’t be reached

The webpage at Kurviger etc etc

Or further use I get;

This site can’t be reached

The webpage at Kurviger might be temporarily down or it may have moved permanently to a new web address.


DNS error ?

Have you enabled the automatic translation feature of Google Chrome? If yes, can you disable it to see if it fixes the issue?

Thank you to everyone. Exporting the route as .kurviger solved the issue of no guidance on turns.

OK that was the issue. I can change it back and forth - German - English and the export file name changes - Kurviger - Curvy.

I followed your link, this is the DEFAULT action:



Making the change in the Browser (Google Chrome) changes the translation of export file format name, but this change in the Kurviger toolbar does not change it (remains Curvy if browser is set to translate to English)


Exporting the route as .kurviger it still shows guidance to Waypoint (shaping point)

Travel beyond the waypoint and Kurviger provides the turn guidance. This was not happening on the exported GPX file because of all the added waypoints, including at the intersection as others have explained to me.

I wonder if Kurviger can be set to NOT ALERT for shaping points.
Those of us who have suffered with Garmin Basecamp have learned to view the details of the route, select all points (other than start and end). Set to “not alert”.

With Basecamp, that helps to prevent unwanted U-turns. The program allows you to keep moving forward if you skip a waypoint (shaping point) which often happens if the point is not placed exactly on the road.

It’s interesting that Google Chrome seems to still think the page would be in German. There seems to be some recent change in Google Chrome, we will further investigate.

I would still really recommend not to place too many Shaping-Points, especially not too close to intersections. Trust me, there will be issues, even if the app can completely ignore them.

Thanks - that was user error of GPX export rather than Kurviger file format.
The default settings add waypoints to GPX file and some are intersections.

Kurviger is working great for me now - thanks to all that helped me.

The arrow I placed in my image above may have been confusing.
By default (in United States) the program comes up with an English flag.
I was trying to show the drop-down to other languages within the Kurviger program

I just tried switching to German within Kurviger and saved a route, it properly saved as Kurviger.
Set for German language the program did not say “Curvy”.
All is well, thanks for your help!

1 Like

Thanks for the update, we are still looking at the weird translation issue and are currently checking if we can disable the auto-translate feature on our end.