Ungewollte Erweiterung der Wegpunkte / unwanted extension of waypoints

Beim Import von .gpx-Files kann man die Anzahl der Wegpunkte reduzieren - siehe screenshot:

Das funktioniert auch - allerdings werden die Wegpunkte aufgefüllt wenn die Anzahl noch nicht erreicht ist, entgegen der Beschreibung. Hier das entsprechende .gpx-File: Schleiz_a.gpx (235.5 KB) - das Kurviger-Format: https://kurv.gr/rmbZJ

Passiert übrigens in KurvigerPRO ebenfalls, vielleicht weil die gleiche Routine genutzt wird?


When importing .gpx files you can reduce the number of waypoints - see screenshot:

This works fine - but the waypoints will be filled up if the number is not yet reached, contrary to the description. Here the corresponding .gpx file: Schleiz_a.gpx (235.5 KB) - the kurviger format: https://kurv.gr/rmbZJ

By the way, it happens in KurvigerPRO as well, maybe because the same routine is used?

If you use “Automatisch” for the calculation Kurviger will use the track, if there is any. You can select a different option if you don’t want to select the track.

Robin, that’s not the “problem” …
You insert waypoints up to the number given in “Reduce number of waypoints” despite your announcement, not to change anything if the .gpx file has less waypoints.
Just try it with my above inserted file.

That gpx file does not contain any wpt points.
It contains a route with 23 points and a track.
(GPX tracks do not have waypoints)

Importing the “Route” in routing (50 waypoints), it uses all 23 as waypoints for the route calculation.
Importing the “Track” in routing (50 waypoints), it uses only 50 as waypoints for the route calculation.

So it seems to work as in the description:
“If your route contains less waypoints than specified nothing will be removed.”

That’s true. I’d have called it RoutePoints - shouldn’t I? But you reduce this RoutePoints naming it WayPoints: (sometimes we use the same name for different items and vice versa …)


The reduction of RoutePoints works with all types in route calculation. The unwanted extention of RoutePoints takes place with “Automatic” and “Track”; only specifying “Route” avoids more RoutePoints.

That’s true again - but: you fill some in, except “Route” is specified.

Btw: It doesn’t bother me much, I just wanted to report a bug.

The number of “input points” from the GPX gets reduced to the number of waypoints used to calculate the route. This refers to the points that are placed on the map.

For example if you would load a track, it might have 10.000 points and you would end up with a route that has 10.000 waypoints. So the number of waypoints is reduced.

Does this makes sense?

Leute, glaubt mir bitte: ich versuche es zu verstehen - allein: es gelingt mir nicht! :upside_down_face:
Bei absolut gleichen Einstellungen funktioniert’s bei einem .gpx-File, beim anderen nicht. Wenn ich mir die beiden Files im Notepad++ anschaue, habe ich allerdings auch zwei verschiedene “Dialekte” von GPX vor mir. :roll_eyes:
Wäre ich stets allein unterwegs, würde ich nur .kurviger-Files verwenden - basta!
Aber “die Anderen” nutzen nun mal andere Produkte und der gemeinsame Nenner ist (leider) GPX.
Die ungewollte Addition weiterer RoutePoints kann ich umgehen, indem ich “Route” statt “Automatisch” benutze - das habe ich nun gelernt.
Danke für eure Unterstützung dabei - und für eure Geduld! :wink:


Folks, please believe me: I am trying to understand - but I am not successful! :upside_down_face:
With absolutely the same settings it works with one .gpx file, but not with the other. When I look at the two files in Notepad++, I have as well two different “dialects” of GPX in front of me. :roll_eyes:
If I was always on my own, I would only use . kurviger files - that’s it!
But “the others” use different products and the common base is (unfortunately) GPX.
I can avoid the unwanted addition of further RoutePoints by using “Route” instead of “Automatic” - I have learned that now.
Thanks for your support - and for your patience! :wink:

1 Like

The misunderstanding probably is on what GPX element is selected in import dialog.
Only one GPX element type is used each time in import: waypoints or route or track.

See my above comment (using the default 50 waypoints option):
The route has 23 points, so the algorithm can use all of them without changes.
The track has over 4.8K points, so the algorithm must reduce them to 50 points.

If the common format had been .json, I would assume this would now show the same inconveniences after several years of use by many different developers ?
However, disguised in the .kurviger format, it will likely protect it from variety. The advantage of a “cocoon” format is one chef one uniform decision.
However, for exchanges with … you need a fall back “fortunately” offered by that common popular gpx format, oh yes, with the usual associated inconveniences.

Könntest du uns mal 1-2 Dateien zu Verfügung stellen damit wir das mal testen können? Ich hab die Datei oben im Thread gesehen, da kann ich aber nichts “unerwartetes” erkennen.

Eigentlich will ich nicht zum GPX-Kenner werden. Lediglich meinen workflow auf Vordermann halten: Import von .gpx-Files und Konvertieren ins Kurviger-Format, aber auch Export von .gpx-Files für Mitfahrer.
Wenn ich mir verschiedene Files in Notepad++ anschaue, sehe ich total unterschiedliche Strukturen … RhönRunde.gpx (92.9 KB) (aus einer Zeitschrift) … Schleiz_a.gpx (235.5 KB) (von mir in kurviger.de erstellt) - bei der RhönRunde werden keine Wegpunkte eingefügt, bei Schleiz_a schon.
Aber wie gesagt: ich will meine Kenntnisse gar nicht vertiefen … fahre lieber Motorrad, wobei sich das momentan auch in Grenzen hält. :confused:

Also mit den Einstellungen (siehe Screenshot) kommen bei der Schleiz Datei 22 Wegpunkte raus. Ist das nicht richtig? Das Overlay kann man ruhig raus nehmen, das hat damit nichts zu tun :slight_smile:

Robin, wir reden (besser: schreiben) ein bisschen aneinander vorbei. Dass es mit “Route” funktioniert habe ich seit 3 Tagen verstanden - wenngleich es bei der RhönRunde auch mit “Automatisch” klappt.
Bevor dieser Thread noch akademischer wird: Alles gut! Ich komme klar damit. Also: nochmal danke für eure Mühe - over and out!

1 Like