Kurviger.de | Application | Blog | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Track not able to be exported

HI all

I´ve imported an GPX Track into Kurviger, changed it slightly, added some additional waypoints and want to export the updated one.
Unfortunately Kurviger is not exporting it for whatever reason independent if track, route or ITN.
Can anybody help me?
when I create a totally new route the export works fine.

BR
Axel

Is it about the application or the website?

Both export the routes when there is internet,
unless use an offline format like the kurviger.

It´s about the website.
As soon as I press export, it will jump to a white screen and stays there without function.
As mentioned. This is only when I change an imported route and try to export it again.

Sometimes an error message appears. Unfortunately I cannot remember the content…

It would be great if you could provide more details. I can’t reproduce this.

What browser are you using, are you using any browser extensions? If there is an error message, please provide this. Without these we can only guess what is happening :slight_smile:.

I´m using both IE and MSEdge. Both are facing problems.

  1. I´m importing an GPX route with automatic calculation settings.
  2. Since Kurviger did not match exactly the imported track I adjust the calculation by setting additional waypoints (I tried to export in between just to see by when I will face problems and in deed the first changes still allow me to export and it works.)
  3. Adding/changing starting point and destination. In total approx. 85 waypoints.
  4. Unfortunately after having everything done the export does not work. I press the export button and choose GPX file, track and medium supporting points. After pressing the button the browser opens a new window which normally stays white without function. Sometimes it complains the there is no access to api.kuviger webside.

When I start my own route from the scratch I don´t face any problem.

I also had the problem when I connected two separate routes to one. Export doesn´t work.

Thanks for providing these additional details. I think this might be related to URLs becoming too long. Could you try with Firefox or Chrome? Usually MS Edge should support longer URLs as well. Is the browser updated? Are you using Windows 10?

BTW: Please don’t use IE, the browser is extremely outdated. More and more websites will stop working with IE.

Does that mean due to too many waypoints the browser is facing problems?? Just 90 waypoints. I don’t believe that

Have you tried it? Try to delete one or two points and try again until it works. Then add a point again and probably fails. Copy the url to recommended Browser and try again.

btw, the error I received in IE was

HTTP ERROR 400
Problem accessing/route. Reason:
Unable to parse URI query

It seems as soon as I stay below 60 waypoints with all the changes the export works.
Unfortunately it´s not possible to reach the required track with less than 80 waypoints.
Could you provide any solution? Otherwise I don´t see any option to use kurviger.de in the future

Yes, you can use a different browser :slight_smile:. IE support for Kurviger is limited and you should not expect that everything works with IE. IE is extremely outdated and should not be used anymore. We try to stay IE compatible where possible, but we can’t stop new features because of IE.

1 Like

unfortunately same situation with Edge or chrome

Könntest Du die Datei bitte teilen? Ich würde es Morgen mal mit dem neuen Edge testen…

Could you please split the file? I’d try it out on the new Edge tomorrow…

The best would be if you could share the specific URL. Import the file and set it up that the export fails, then share the URL, so we can have a look what is causing the issues.

https://api.kurviger.de/route?point=49.287792%2C10.659973&point=49.39882%2C12.18668&point=49.43727%2C12.58283&point=49.46291%2C12.59706&point=49.50988%2C12.54718&point=49.58346%2C12.52029&point=49.61034%2C12.53105&point=49.6195%2C12.49642&point=49.71896%2C12.42047&point=49.72513%2C12.33684&point=49.75158%2C12.38809&point=49.7918%2C12.37024&point=49.82099%2C12.44825&point=49.86758%2C12.47205&point=49.90152%2C12.54398&point=49.8893%2C12.60637&point=49.90859%2C12.59694&point=49.93595%2C12.62022&point=49.95114%2C12.73426&point=50.04771%2C12.79582&point=50.03909%2C12.82698&point=50.19791%2C12.85903&point=50.21219%2C12.82544&point=50.22727%2C12.84575&point=50.2438%2C12.99171&point=50.32691%2C13.01887&point=50.37285%2C13.0871&point=50.35975%2C13.15682&point=50.38532%2C13.17226&point=50.45468%2C13.37771&point=50.46945%2C13.37368&point=50.4903%2C13.27123&point=50.55766%2C13.21947&point=50.55763%2C13.15209&point=50.51236%2C13.0995&point=50.51106%2C13.03011&point=50.48258%2C13.00916&point=50.44614%2C13.01831&point=50.41215%2C12.93692&point=50.47698%2C12.78054&point=50.47688%2C12.72831&point=50.43702%2C12.71732&point=50.4307%2C12.64914&point=50.44953%2C12.63108&point=50.43558%2C12.58434&point=50.47449%2C12.51462&point=50.42345%2C12.39765&point=50.45916%2C12.16221&point=50.43851%2C12.11524&point=50.46318%2C12.06965&point=50.4315%2C12.00634&point=50.40556%2C11.81995&point=50.44429%2C11.76405&point=50.44713%2C11.64203&point=50.43604%2C11.65417&point=50.42804%2C11.63585&point=50.38336%2C11.67581&point=50.31593%2C11.61256&point=50.28658%2C11.62719&point=50.28451%2C11.66211&point=50.24732%2C11.65802&point=50.21741%2C11.69569&point=50.11848%2C11.69788&point=50.0726%2C11.77279&point=50.01621%2C11.79252&point=49.9441%2C11.75448&point=49.93902%2C11.71948&point=49.8646%2C11.68491&point=49.77503%2C11.70832&point=49.7489%2C11.66731&point=49.6796%2C11.62965&point=49.62461%2C11.54495&point=49.58461%2C11.54203&point=49.5809%2C11.48663&point=49.56906%2C11.49957&point=49.53686%2C11.46631&point=49.51652%2C11.49045&point=49.4

How was such a route url created?

The Kurviger urls start with: https://kurviger.de/?point=

That’s the URL which Edge opens in a new window as soon as I press the Export button

Please post the URL of the route. The above URL is not complete and won’t work in other browsers as well.