Route information announcements too quiet


there are a few post here on the forum, regarding too quiet announcements.
I was following all tips and tricks without success.
i have to level up the radio (speech is transfered via bluetooth) so that the music is playing very loud.
Measured with dbMeter at 98 dB…
But only then is the announcement loud enough
what i’ve did until now was:

  • install the speech TTS from google
  • rasied the speech volume within this TTS app
  • raised the volume of the device itself to 100% (media ,announcement, every volume level button i could find…)
  • changed the speech channels within kurviger

it’s just too low volume.
I didn’t have this with other apps…

My information:
Device:Raspberry - Raspberry Pi 4 - Android 14 -Webview
App-Version 3.3.0 - 2270
Screen: 1067x640 px - 0.75dppx

If you switch the channels, you can set different volume levels per channel. So for example you can use the notification channel for Kurviger and raise the volume for the notification channel, but keep the music at a lower level.

That said, have you tried the lastest BETA 3.3.2? We improved the TTS output.

yes i’m aware that i can raise the volume differently for each channel.
But this is a pita on the raspberry cause this device has no hw buttons.
perhaps i find a software tool which allows me to set the volume level on every channel easily and also stays there fixed after a reboot… recommendations welcome. :slight_smile:
…and no haven’t tried the beta. looking for it now.

tested now the different channels (with latest beta)
even though i can select three channels (media, notification, telephone) the channels are not equal with volume (of course i’ve raised either channel seperately).
The loudest channel is media, the lowest is telephone. Both channels telephone and notification are quite useless because volume is too low.

1 Like

Ok thanks for verifying, we will see if we can further improve this in the future :+1:

1 Like

another observation:

  • volume of Notification is on 100%
  • volume of media is on approximately 30%
  • navigation is running

raising volume of media during navigation raised the volume of the direction speaking woman also…

shouldn’t be the case, as notification is already on 100%, isn’t it?
not clear if this is different if i cut bluetooth before i change the kurviger output channels…

…no definitely there is something wrong. The kurviger lady is still linked to the media channel even though not selected in kurviger.
Max volume on telephone/notification channel isn’t max device volume…
i have still to raise media volume to get more volume from the other channels
makes the differentiation to seperate channels quite useless.

1 Like

We can double check if we can further improve our implementation. That said, all this is essentially completely handled by Android. We don’t set the volume, Android is deciding the volume. So it could be related to your TTS as well. Are you using the Google TTS?

yes, google TTS.
I have more observation about this after my R&D drive yesterday. :slight_smile:
I do not agree that this is 100% android. see below

  • If a bluetooth device is paired, there is a cog wheel to configure some settings. Depends on the paired device. There you can find the “type” of device. If it is set to “unkown” (happen sometimes), then speech is quieter than if set to “loudspeaker”
  • if (in developer settings" the value " Absolute Bluetooth Volume" is turned on, the volume is quieter than if turned of,

… and the following is the interesting part
i have tested with several music apps, settled on “musicolet” and “poweramp”

  • using poweramp, then the speech is quieter BUT, if started musicolet, the speech volume is louder… then going back to poweramp, the speech volume is also louder there…(?!)
  • using musicolet the speech volume is constantly on louder level without the “poweramp glitch”

speaking above about “music channel” always.

As the channel volume seems to change regarding to music app, my impression is, that the music apps are doing more with the channels than kurviger and kurviger should “reset” those stuff upfront.

Thanks a lot for providing all these additional details!

It is absolutely possible that some apps might do some additional things. But we don’t know what these apps are doing, and if it would be possible for us to change this as with TTS we can only control a limited set. We will see what we can do about this, but I can’t promise anything.

Your problem may be your intercom settings. I was able to fix my volume issues via Cardo Settings as shown in the picture below.

i didn’t have this in my android 14 settings…

My apologies. I’m not being clear. Let me add some detail. Get your Cardo unit and turn it on. Get your phone and open your Cardo Connect App on your phone.

If you don’t have the Cardo Connect App on your phone, go to the Google Play Store; find it by searching on “Cardo Connect”; and install it. Once installed, open it and it should automatically connect to your Cardo unit as long as it is turned on. It’s been awhile since I went through that process for the first time, so there may be some steps to doing that. If it doesn’t connect, completely close the app and reopen it.

After your Cardo unit and Cardo app have connected, touch the gear in the upper left to open Settings; then touch Audio Settings; then touch Volume Levels; then experiment with changing the Volume Level settings to see if you can find a combination that solves your specific problem.

I had to do some test rides while finding the settings that worked for me. My settings are shown in the last screen shot below, but I use custom molded ear buds plugged into my Cardo unit, so my settings probably differ from someone who is uses Cardo’s helmet speakers.

I hope this helps.

This is the Play Store Cardo Connect App page:

This is the app trying to connect to your Cardo unit:

This is the app Home Screen that appears after the app connects to your Cardo unit:

This is the Cardo app Settings Screen that appears after touching the gear symbol on the above screen:

This is the Audio Settings screen that appears after touching “Audio settings” on the above screen:

This is the Volume Levels screen that appears after touching “Volume levels” on the above screen:
(These specific settings are the what I use with my Cardo unit and my custom molded ear buds.)
(I zeroed out FM Radio only because I never use Cardo’s FM Radio.)

1 Like

thank you for your detailed recommendation.
I haven’t tested your app yet, but now i have to, because i have used an other approach which might be also interesting for other users and/or the kurviger team.

the kurviger team always recommends the google tts. i had the impression, that the google tts was/is not the only (best) solution, so lets try another one. BINGO!

i’ve tried acapela TTS (you have to buy a voice there, but it’s worth it), i have now a voice at FULL volume. Not these quiet google tts voices…

Now i’m a step further but need to test with your recommndation to bring down the volume of the voice speaking.

1 Like