Problem with program hangs while pausing and resuming a tour

I just discovered the same problem in Kurviger 2 as mentioned before in Kurviger 1 Pro that two buttons are marked in blue and none of them is working. When pressing on proceeding the route after pausing, it doesn’t work. I had the effect again yesterday on the tour with Kurviger 1 Pro and now again in Kurviger 2.0 in simulation mode. I don’t know when exactly it happened. I was just simulating a tour and then played around with the color option and suddenly the program hangs, the tour can’t be proceeded, nor can it be stopped and started again. The program has to be quited and started again. It is like an endless loop for the current tour.


This is strange, I have never seen it happen.

But you can believe me that it is a real issue. I have it on almost every tour since weeks. Maybe the others don’t drive quite that often than me :slight_smile: . If I knew how to reproduce it safely, I would say so.

On today’s tour I had this problem again 2 times. I paused the routing, then used some other apps in the foreground then wanted to resume my tour and then no buttons worked, neither pressing again on the routing button, nor the menu button worked. Again both were marked in blue. Thank goodness the workaround is easy: closing the app and starting again. Because the last tour is reloaded and can then poceeded from that point. Nevertheless it is a bug which already existed in 1 Pro version. I can’t understand why no one else had this problem so far. Did you already start the new season? (little joke :slight_smile: ). Strange is that it doesn’t happen all the time (difficult to find out the root cause).

You probably mean navigation.

Pause / resume navigation is a convenient function to get away from device.
Not putting the app in the background and open many other apps on top.
Then Android can very easily kill any background app for memory etc.

Very strange statement…
…considering that you are a user who is constantly reporting that no one else can reproduce.

Yes navigation

Ok then this could be a reason. But I also did this already since the convenient pausing navigation existed and it worked all the time without a problem, only since around 2-3 weeks I discovered this effect already with 1 Pro. I try to verfiy on next tour if the problem still exists when I leave Kurviger in the foreground and just switch off the display. I will use other apps like weather check on the second smartphone then.

I don’t find this strange (please look at my comment, it was with a wink. Irony never hurt anyone who understood it. Sarcasm is something else, it has an evil underlying tendency. But my comment was ironic.

I never reported any faked problem. When I report something, then I have this problem real. I drive far more than 30.000 km per year with the motorcycle and my mostly used app in the last years was Kurviger (it already burned into the screen of my Samsung S9+ :rofl: … no problem, I don’t mind). Where should I put the report if not in this forum? I can’t ask Tomtom, whose support is lousy. Navigon doesn’t either, it’s no longer supported. It still runs more badly than good on my smartphone :slight_smile: .

I hate to admit that the same thing happened to me today. In three years for the first time. The sequence of events:

  1. stop at a parking lot to call home - in “route missed” status.
  2. navigation not stopped, just used the phone function in foreground
  3. when driving on, everything was frozen, no movement on the display at all
  4. the navigation icon had a blue background
  5. stop and restart of the app brought no improvement
  6. only the restart of android helped

Sorry - but I can’t offer more details …

This must always work, specially if it is removed completely from recent apps.

This is not normal, seems more like Android or device temperature problem.

Okay - I can’t remember if I’ve removed it from “recent apps” … may be not?
And I was in stress, because I recognized the situation while driving (following my friends) - therefore no analyzing and error handling, just panic restart of android. :confused:
Next time I’ll take time - promissed!
But another detail - kurviger was recording GPS data and the original file shows the following for the time of the failure (the break was longer, we took lunch as well):

(screenshot of NotePad++)
Perhaps it gives you a hint, Emux … :neutral_face:

1 Like

It not removed from recent apps, then apps just resume their previous state,
they do not do a fresh start.

This looks like consecutive starts / stops of GPS logging (by who?).

Quite sure not to stop/start GPS recording - since this wasn’t my problem …
But I did several stops/starts of the app itself, may be these caused the entries.