OSM - Kartenfehler

Hier habe ich zwei Kartenfehler gefunden.

Die anderen Variationen stimmen wohl.
Mir ist das zu kompliziert um den bei OSM zu korrigieren.

1 Like

Habe Kehrtwenden bei der Auffährt verboten, mal sehen, wie weit das hilft.

Eine gute Beschreibung, wie man einfach Abbiegebeschränkungen eintragen kann (Bildschirmvideo), findest Du unter
Simple Editing for Turn Restrictions in OpenStreetMap | by Mapbox | maps for developers.

4 Likes

Auf diese Korrektur wäre ich nicht gekommen. Mal sehen wie das sich später verhält.
Danke f√ľr den Link, da kann man sicherlich mal an einer einfachen Kreuzung rumprobieren.

Merkw√ľrdig ist aber schon, bei der OSM-Freizeitkarte von Dez 21 wird die Route unter Basecamp richtig angezeigt.

Die Verwirrung ist dann komplett, wenn ich unter www.openstreetmap.de die Korrektur eintragen soll. Von dort routing.openstreetmap.de oder classic-maps.openrouteservice.org augefrufen wird die Stelle korrekt geroutet.
OpenStreetMap Routing with Open Source Routing Machine

Da blicke ich nicht mehr durch

1 Like

Hilft! :slight_smile:
Die beiden oben verlinkten Routen werden jetzt richtig berechnet.

1 Like

Ja, es hilft. Was ich aber nicht verstehe. Diese Stelle ist mit durchgezogenem Mittelstreifen bis weit √ľber die Isar-Br√ľcke versehen.

Mir fiel noch diese Stelle vom Juni letzten Jahres ein. Hier aber andere Straßenmarkierung

Schiebe ich den WP1 weiter, U-Turn
grafik

Ein Meter weiter verschoben sieht es dann so aus
grafik

Noch mal einen Meter weiter
grafik

Und nun mit einem neuen WP das Freisinger Problem. Perfekt geht runter bis zur Abzweigung und wieder zur√ľck
grafik

Wieder einen Meter weiter - U-Turn - obwohl durchgezogener Mittelstreifen
grafik

Der U-Turn geht bis zur der Abzweigung
grafik

Und nun den WP1 auf Br√ľckenmitte gelegt, BaseCamp macht das korrekt
grafik

Kurviger dreht auf der Br√ľcke
grafik

Das ist doch eine Standardsituation. Wenn doch beide ein OSM-Karte nutzen, dann können doch nur die deutlich verschiedenen Algorithmen diese Unterschiede herbeirechnen.

1 Like

Die (etwas wirre) Aneinanderreihung von Screenshots verstehe ich nur teilweise - ein Kritikpunkt scheint mir, daß Kurviger auf der B301 bei Freising umdreht, obwohl dort eine durchgezogene Mittellinie ist.

Da weiß ich auch keine Lösung, evtl. sollte sie mit highway=trunk getagged werden (Kreuzungsfrei ist sie ja anscheinend).
https://wiki.openstreetmap.org/wiki/DE:Tag:highway=trunk?uselang=de
Frage an die erfahreneren Mapper: Gibt es eine andere M√∂glichkeit, das Wenden zu verbieten (√ľber lanes und change o.√§., oder √ľber Relations, die als via ebenfalls ein oder mehrere Wegst√ľcke eingetragen haben)?

1 Like

Am besten funktioniert das mit 2 parallelen Einbahnstraßen. Dann ist es garantiert erzwungen und wird von jedem Router richtig gemacht. So sollte aber nur getagged werden, wenn die zwei Fahrspuren wirklich getrennt sind.

Ansonsten ist es leider technisch sehr schwierig das zu erzwingen.

Stra√üenst√ľck markieren
Dann nach unten scrollen
relation hinzuf√ľgen
Kehrtwendeverbot


click on road segment
scroll down
add relation
turn-restriction

Edit:
Seems only to work for junctions - not in the middle of a road

1 Like

Das gilt aber nur f√ľr die Kreuzung, nicht wenn der Wegpunkt auf der Stra√üe liegt.

2 Likes

@rumbrummer - mir war bewusst, dass die Darstellung nicht optimal ist. Wusste mir aber keinen anderen Weg

Hier erweiterte Routen mit der Umdrehproblematik obwohl durchgezogene Markierung.

Beide Etappen wurden mit Kurviger und Option ‚ÄúSetze Wegpunkt auf die Stra√üe‚ÄĚ erstellt.

Beim ITN-Converter sieht man wie sich mit TomTom Karte/Routing die Route verändert, die Fahrbahntrennung tritt deutlich hervor. Zudem deutlich veränderte KM von 18,27km auf auf 40,4km. Und das ist nur ein Teil der B300 die sehr oft 3spurig ist und dann sehr oft die 2spurigkeit hin&her wechselt. ODM kennt aber hier nur eine Spur/Lane

Ebenso in Tölz. Kurviger sieht dort das Problem nicht. Mit dem ITN-Converter wird ganz vertrackt von 2,7km auf 11,7km erweitert.

Ich denke solche Fahrbahnen geh√∂ren, wie oben schon von @boldtrn vorgeschlagen, als ‚ÄúEinbahnstra√üe‚ÄĚ ausgewiesen. Damit w√§re ja schon der obige Eingangsfehler weg.