Kurviger stops the Podcastplayer or music

Hi,

I used the Beta some days ago on some routes through the northern of Germany.
Most worked well. :+1:t2:
One problem was that the speech of Kurviger sometimes stoped the music or the podcast I heard before. Sometimes it was just a little pause, sometimes I had to start the podcast via my communication again.

I used the Beta. My smartphone was mounted on the bike and linked to my Bluetooth-Headset. The sound was good, the speech was understandable. But this problem made me to disable the speech because it was annoying to start the music or podcast from time to time.

I can’t really describe the situation when the music stops and doesn’t only pause and play again.

Cheer’s,
Jonny

Thanks for letting us know.

If I understand you correctly, this only happened sometimes, was it like every 2nd instruction or more like every 30th instruction or somewhere in between?

Have you only tested this with one music/podcast app? If yes, what app are you using?

Can you provide more information about your smartphone, Android version, etc?

For sure you can get some more information.

I got the problem with my podcast app (podcast addict) and with playing music on spotify. The problem was not every 2nd time, but much more than every 30th time. I think it was about every 5th-10th time. I can not say how to repoduce that. I will try again and will tell u if I have some ideas what it could be.

I have an android phone. It’s a Google Pixel 5 with Android 13. If you need more information, feel free to ask.

2 Likes

Thanks for adding more information, it would be interesting to find out what is happening on your device, I just checked with Spotify, when an instruction is spoken the playback is not paused, but the music is faded.

I tried it with about 20 instructions.

Is the same happening without your BT headphones? You can try this at home using navigation simulation.

Okay, I have to admit that I was maybe wrong. I tested it with both apps again. And Spotify works well as you wrote it up here.

The issue is just with podcast addict and maybe it’s not a problem of Kurviger but a problem of Podcast addict or my settings…

I will test that again and have a look in the settings. Sorry for making that noise… :face_with_peeking_eye:

Yeah. In the Podcast app you can select what the player should do if another app asks for the sound for a notification or something. The possibilities are 1. do nothing, just play 2. volume the podcast down 3. pause and play again. The last one was selected, but sometimes it doesn’t started again. So I don’t know if this is a problem of Podcast addict or kurviger, but selecting volume down helps a little bit, but I can’t understand what the podcast tells me, so it’s not the best option for me. It would be better to pause and play again, if it would work well… :sweat_smile:

1 Like

It would be interesting if you find similar issues with option 2 (sound lowered / faded), especially if the same is also true for other apps. In my tests so far lowering / raising the sound worked well with Spotify. Kurviger is asking Android to play sound (that’s when other apps volume get lowered) and tells Android when it’s finished (then the apps continue normal). How apps behave is in their implementation.

Maybe there is also an issue with the BT headset in combination with continue playing. I checked the latest reviews from Podcast Addict and couldn’t find error reports there, so I doubt this is a general issue with their app.

1 Like

I will test that with some other navigation apps. Lowering the volume works fine with podcast addict I have tested that.

I now worked with three BT speakers/headphones. One was the headset in the helmet, one BT over the ear headset from Bose and the BT connection to my car. On all three the bahavior was the same.
I will also test that with the speaker from the smartphone to be sure it is (not) the BT connection.

1 Like

Well the good news is I also use Podcast Addict, Spotify, a Google Pixel (6) and a bluetooth headset, so we should be able to test this problem and narrow it down if we can reproduce it :slight_smile:

I just checked this setting, I also have it set to pause / resume (which I assume is the default, I don’t remember changing it. I used this setup extensively during my recent vacation, while running Kurviger, and I did not see this problem pop up

Have you tried to report a bug at Podcast Addict and see if Xavier has something to say about this?

Sorry for the late reaction…

I tested it without Bluetooth and the behavior was the same. I tested it with some other navigation apps and it does not appear there.

Until now I did not reported a problem to podcast addict, because Kurviger was the only app with this behavior while routing me.

Hi Jonny,

Very good, that makes it potentially easier to find the problem

I just checked our code and we absolutely request audio focus like this: AUDIOFOCUS_GAIN_TRANSIENT_MAY_DUCK which means we give up the audiofocus as fast as we can and other apps are allowed to “duck” (lower their volume) instead of fully pausing. I cannot see anything in the code that would lead me to believe this is fixable on our side. Do the other navigation apps you have tested with pause your audio in Spotify/PodcastAddict or just make them duck like we try to do?

Maybe ducking is buggy in some Android versions and we should request focus without it? Maybe we can do some investigation here in the long term, but short term I can’t do much more for you, sorry

I’m not sure about that, I will try that another time with some other apps. :muscle:t2:

1 Like

I have been using it and really like the Kurviger now, despite the audio issues. The cloud support and offline maps and creating routes in the app is very nice.

When I listen to podcasts using Doggcatcher, the podcasts are paused when Kurviger provides a navigation prompt, and then sometimes not resumed… But when I’m listening to music (PowerAmp) the music volume is lowered, and then consistently raised back up. Is it the app (Doggcatcher/PowerAmp) which determines this behavior, or is it Kurviger?

Another observation: Somewhat consistently (90% of the time?) the sequence is like this:

  1. I am listening to Doggcatcher

  2. Kurviger announces the next turn 2 miles in advance

  3. Doggcatcher is resumed

  4. Kurviger announces the next turn 1 mile in advance

  5. Doggcatcher is NOT resumed, so I manually resume it

  6. Kurviger announces the next turn 1000 feet in advance

  7. Doggcatcher is NOT resumed, so I manually resume it

and then the pattern resumes for the next navigation prompt.

I don’t see that Doggatcher has the ability to lower volume vs. pause/resume but I wonder if that’'s the issue? Could it be an issue with Doggcatcher not handling the ‘duck’ intent (does Android still use intents? I have done Android coding for nearly a decade). Or does Kurviger use different methods to regain/resume at different points in the navigation?

Does it work as expected if you are using PowerAmp and ask PowerAmp to pause the music?

We don’t do anything different for lowering the volume vs. pausing the volume. We give other apps / the Android OS the option to decide what to do.

My feeling would be that it might be an issue with the other app.

Android is still using Intents. For voice output, we don’t use Intents though.

One more idea would be to change the TTS app you are using. On Samsung devices, the default is S-Voice. In our experience Google TTS works more reliable.

1 Like

I’m still having this problem (Doggcatcher audio isn’t resumed).

Pixel 6, Android 14.

I’ve tested with a different app (Pocket Cast) and that too has issues - similar, but not quite the same. I’m using a Pixel 6 with Android 14. I’ve tried using a number of other apps (Rever, Osmand, Google maps) and they all properly pause and resume audio (Doggcatcher, Pocket Cast, PowerAmp).

Everything comes back to the new Kurviger doing something different than the old Kurviger and a number of other nav app’s.

Thanks for the update. Could you clarify if you used 3.3.1 or 3.3.0? We have improved a few things regarding voice instructions in 3.3.1.

I’m on 3.3.0 - where can I get 3.3.1 to try it out?

Google Play update ?

I see it was released last week but apparently I didn’t get the update until yesterday. I’ll give it a spin on my next ride. Thanks!

You can always start the update manually in the play Store, may auto update is disabled or only allowed in WiFi…
Ride save