Import gpx from, all failed

Edit3: I changed the file extension and got a different error. See screenshot.

Edit2: I was confused. My first edit (below) is incorrect. Step 2 is necessary and results in the error message shown in the screenshots. Help would be appreciated.

Edit: I’ve been doing 2 steps. 1. Tap “Drag & drop” 2. Tap import. It seems that step 2 is unneeded. I could not tell that the import had occurred. It seems to work now. Thank you.


(Debug information, this helps us helping you, you can remove this if you don’t want to share this data, it should not contain any personal or sensitive information)
Device: Google - Pixel 3 - Android: 12 - WebView: 119.0.6045.194
App-Version: 3.2.5 - 2014
Screen: 393 x 786 px - 2.75dppx

Hi Geometer, we’ll need more details to help you out here.
I just tested this by going to the website you mentioned and downloading the first route I saw, which was this one:

I downloaded the GPX and imported it into Kurviger like so:

and it all worked fine for me.
So please tell us which import is breaking for you and how. And maybe also add a screenshot and more details

You’re example failed for me. See screenshot.

I’ve been doing 2 steps. 1. Tap “Drag & drop” 2. Tap import.

It seems that step 2 is unneeded. I could not tell that the import had occurred.

Your filename doesn’t end with .gpx but with .html
Look at filename!
It ends with Pissos--.gpx.html

Please also note that on this forum you can edit your posts, no need to post several different answers, which makes it harder to read this thread :slight_smile:

Just for your information, I tried with the corrected file name extension. I got the error shown in the screenshot included in the post at the top.

So the problem seems not only be the file name but also the content. I think your download from BBR wasn’t correct.

If I use this (official) download button it works … bbr-rte-EN-103-_-Chaves.gpx (188,9 KB)


I use the same icon/link.

Could the contents be compared? See attached.

bbr-rte-EN-103-_-Chaves.gpx (188.9 KB)

Edit4. I can’t seem to be able to edit the original post so I updating through the comments.

I downloaded a GPX from here and got an error also.

Note: I am doing all this on an Android phone and my web browser is Chrome.

The content of both files matches - despite I used BestBikingRoads .com instead of .fr … coundn’t be the problem.
Perhaps you can take another browser? Or at least clear the Chrome cache?

I tried to reproduce with the file you have uploaded here in the forum:
Here the steps i did:

  1. Download the file, than in a separate step open Kurviger App
    (There may be a shorter way, but that is what I did.)

  2. Select import

  3. Tap “drag & drop or click to select”

  4. Select the file

  5. Tap “import”

  6. Voila the route is there