Export GPX without Shaping Points but with Waypoints

I have been unable to export a track and waypoints, without the shaping points showing up as well in the GPX file. I have unchecked the “Export shaping points” option in the UI dialogue, but the shaping points still appear as waypoints. Is this a known limitation with a GPX export, or am I doing something wrong? This is how I have configured my eport.

Can you share the link and also the generated file to that route.
In this way it would be easier to help you … :wink:

Hi Dennis,

the export options look ok, but how about the import options? In which device did you import the route and how are the import options configured?

Here is a link to the file:
And here is a link to the route:

There are 2 shaping points and 2 via points, but in my exported GPX file, the shaping points remain.

Thank you for your help!

I have tried importing the GPX file into Google My Maps, OSMand+, and Locus Classic, with the same results in each interface. I have not been able to find any import settings that will show only the via points created in Kurviger. All shaping points and via points show up in the receiving apps.

Thank you for your reply!

I didn’t find a detailed description of “Export shaping points”, only this:

But I tried it: if the checkmark is set at “Export shaping points”, then shaping points remain shaping points, otherwise they are converted to via point. See comparison of two files:

Left with “Export shaping points” set - Right without …


Thank you for your analysis and input. That is helpful information. I hadn’t considered using the “Export shaping points” option to at least categorize those points differently. That allows me to easily change the appearance of those points, or even delete all of the shaping points, after import.