Can't import a route, a popup is telling me there is no access

The message is: has no access to content://media/external_primary/file/1000008200

But the file is on the phone and not external, and I can import to the web site on my PC from the phone.
does any know what this means?

Regards, Rob

Can you provide more information about your device or share the debug string, that you can find in the settings of the app?

This sounds a bit like a weird Android bug, I am not really sure why this happens, maybe you can share a bit more information, media external does very much sound like a SD card, which is considered external. Usually importing a file from external should work, but external folders are unfortunately troublesome in Android, what you can do as a workaround is to copy the file to the internal storage using a file manager.

1 Like

Also I would like to ask you to please send a screenshot of this as well :slight_smile:

Thank you both for your reply.
My phone is a S22 and has no SD card slot so it is on the internal memory of the phone.
I created the export file on my PC and transfered it by bluetooth and by the exploder from my PC to the phone.
Both are ending with a failure.
I will add a screenshot of the failure and debug string

I don’t have a clear idea of what might be wrong here. Just to rule out a temporary issues, have you tried to restart your device?

It would be nice to check, if there is a (virtual) sdcrad in your phone.
I used the Samsung file manager (Files from Google will do as well) to find my devices.
For example like this:


Hi, I’ve looked around in the android forums for galaxy S21 and S22 and I think I may have found something. It seems that sometimes Samsung revokes file access for some file types specifically.

Could you please go to your phone settings and in the “apps” section click on the 3 dots at the top, click “special access” and look for “all files access”? There could try to give this permission to kurviger and to the system process “External Storage” and try again please?


Tahnk you all for the reply,
I rstarted en reinstalled it now a few times without any result.
@ Patrick
I tried this but Kurviger is not in the list so I don’t know if it is allowed or not.
Tried it on my old S9 phone and have the same problem here.

Please also check the second part of my sentence above: try to click on the 3-dot button at the top again, show system apps, then look for “external storage” (or any other process that sounds like it has to do with file handling and storage) and give the permission there as well

Hello Patrick,
Sorry that i was not clear on this subject but the answer
“I tried this but Kurviger is not in the list so I don’t know if it is allowed or not.”
So I did try butnot on the list.

Exactly, but other apps are in that list. I want to make sure you have this switch enabled for all the apps that could have an impact here - most of all any app called “External Storage” or similar

To make sure that all apps are shown, click on the 3-dot button at the top again, then click “show system apps”

1 Like

Hello Patrick,
Thank you for your reply.
I did check it and the external acces is switched on so it should have access.

1 Like

Dang, then I’m fresh out of ideas.
Can you please try to open the same file with a different app, maybe Locus Map or the old Kurviger 2 app? Can you browse to the file with a file manager, like “Google Files” or “Total commander”? Do other GPX files work in Kurviger?

1 Like

Hello Patrick,
If I export it as a GPX instead of a kurviger file it is possible to import.
So it looks like that the problem is with the kurviger app and android with the kurviger file extension, same on my old S9 phone.
I suppose the gpx will be the standard for export
Thnx a lot for you support

No - the .kurviger files are the proprietary format, which transports all route settings. So you should use that format.
As a workarount you can transfer your route from website to K3 app via Kurviger cloud.

1 Like