Kurviger.de | Application | Blog | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Building numbers at the 17.0 zoom level

I assume that building numbers should appear at zoom level 17. This is very well chosen, but now they appear closer to 17.1 than 17.0 (that’s why in another topic I applied for entering the zoom resolution to one decimal place in the auto zoom settings).

Please, if possible, change the building numbers to appear at zoom 17.0 (or maybe 16.9 easier?) during automatic zooming.

Thank you for your hard work. I really appreciate it and please forgive me for asking so many things so often… :no_mouth:

All POI are set to appear on integer zooms, house numbers on 17.
That’s how map engine works and can better check it if zoom slowly.

Note that map scaling is continuous. So one decimal of displayed fractional zoom represents sufficient zoom gesture move. Also there is the number rounding that can confuse our eyes.

I’m always happy to discuss anything that can improve the application experience. :slightly_smiling_face:

But that’s what I mean - that it doesn’t work! I have set the maximum automatic zoom to 17 and even though 17.0 is reached (as the advanced scale shows), the building numbers are not there. They appear when I manually slightly zoom-in, although it still displays 17.0. I have the impression that buildings appear at the zoom value of 17.05. Please check it.

This is also my goal, as a mature motorcyclist who loves trails away from the main roads :smiley:

The map engine works with integer zoom levels in map styles, so it’s integer 17.

The rounded zoom at 1st decimal is displayed, so actual 17 could be “a bit later”.
i.e. 16.95 ≈ 17
(unless change the rounding function so can be less confusing :thinking: )

Unfortunately, this is not a case of rounding. I thought maybe “17” is not defined as “=17” but “>17”. But this is also not, because I noticed that when zoom 17.0 is automatically reached “from below” (i.e. zoom-out from level 18) the numbers do not disappear and still appear at level 17. So it all depends on whether zoom-in or zoom-out to level 17 :thinking:

It is a rounding case for the displayed zoom, as 17.04 (like 16.95) is rounded as 17 too.

I perfectly understand the rules of rounding :slight_smile:

A moment ago (during the simulation) I noticed a different behavior: a moment after reaching declared on the scale zoom 17, before the maneuver (I remind you that I have set it as the maximum before the maneuver), the building numbers correctly appeared but only for literally half a second and disappeared.

So maybe the problem is in the map zoom algorithm that it is not “holding” level 17 correctly before maneuver? It’s like circling around 17 from e.g. 16.99 to 17.01 and back to 16.99 :thinking:

Auto zoom obviously is not fixed on levels, it’s a fluid process in real time with double precision.

It’s not integer, not float, not rounded in whatever decimals the UI shows for user convenience.

Auto zoom options allow [12…20]. If make them decimals, would help, e.g. can set max 17.1.

Thanks for the explanation. This is exactly what I imagined. :slight_smile:

Absolutely right. Because 18.0 is far too much!..
Edit: OK, on ​​the phone screen zoom 18 is not far too much. I still look at my 8 "tablet :wink:

1 Like

Kurviger 1.11.10 contains an improved (fractional) zoom display with revised rounding, which should help understanding better the layer zoom levels.