Kurviger.de | Application | Blog | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Audio Navigation switches language

Hi,

apart from my waypoint question I noticed another problem with the Kurviger App during my day trip in the Cote d’Azur hills.

My system language is set to US English with German installed as second language. My Kurviger App language is set to German for both, the App language as well as the navigation language.

During the trip, I often paused to take photos and/or to chat. These actions push the Kurviger App obviously into the background. After pulling up the Kurviger App into forground to continue navigation, the navigation switched to English. Stopping and starting the navigation didn’t change this back to German. Only leaving and restarting Kurviger reverted the navigation language back to German.

This isn’t much of a problem, especially given the “split language” personality as I’m using it is probably rather rare. But if there’s an easy fix…

Thanks,
Corinna

Thanks for the details, trying to reproduce that workflow and could not. :confused:

Only the voice language changed? What language appeared in its settings?
What was the app language when pull it to foreground, German or English?

Can you give more info, like Android version and device model?
Does it happen with every other app & what was the photo app?

It was only the voice language. The app language was still German.

The voice language in the setting was still set to German. I tried to switch the language in the settings so I noticed.

Samsung S5+ with Lineage 16 (Pie). I wouldn’t be surprised if this problem is a system problem, rather than an app problem…

In fact I only used one other app during the trip, for chatting plus taking the photos. It was the chat app Signal.

Thanks,
Corinna

Can you reproduce it every time, when push app in background?

Unfortunately it’s not that simple. During my trip the problem only occured after leaving Kurviger for a few minutes. Just starting another app and returning to Kurviger didn’t trigger the language switch.

Today we tried to reproduce the issue during a tour by car. We didn’t manage to reproduce the audio language switch but we managed to see temporary language switches in the mavigation output, even while Kurviger was in the foreground. Two noticable occurrences:

  • “recalculating route” in English instead of German and
  • “press again to exit” in English instead of German.
    Menu and settings were still in german, as were the actual language settings for App and navigation. Checking the app language in menu and settings reverted the shown language back to german.

The difference between my bike tour and the today’s car tour were:

  • BT headset vs. phone speaker output
  • During the bike tour I switched off the display all the time because the phone was in my jacket pocket. today we had the phone display running basically all the time.

I’m sorry, but i don’t see any reproducible pattern at the moment. Perhaps this should be put on hold until I find a way tp reproduce the problem more reliably :thinking:

Thanks,
Corinna

1 Like

Thanks for providing such a detailed description!

I have both English and German TTS installed on my device as well and haven’t seen such issues to be honest. It would be interesting to see if we can find any way to reproduce this. Are you on a nightly Lineage? Maybe there is a bug in the current nightly? Are there any OS updates available?

1 Like

Sorry for the late reply, but I really had nothing to follow up . However, now I have.

As for the OS question, I’m running a derivative of lineage 16, called Resurrection Remix 7.0. The code is the latest available. It wasn’t during my vacation but is now, I’m Lineage and Resurrection Remix maintainer for my device.

I’m now reasonably sure that the language problem is an OS problem, I just don’t know if it’s Lineage or RR only. The reason I’m sure is that I encountered the same problem as outlined for Kurviger in another app, Duolingo! I’m doing French lessons in German and at one point during a course I pushed Duolingo into background, did something completly different, and when I returned to Duolingo, the application language (not the course language!) had switch to English.

Given that, I don’t think it makes sense to spend a lot of time with this issue. Apparently it just occurs in an obscure Android for an obscure device :blush:

Thanks,
Corinna

1 Like

Thanks for the extra info, that’s unfortunate to happen.

Very nice having Android ROM maintainers in our community. :slightly_smiling_face:

In the past I have seen issues with some roms, e.g. KDE Connect caused an old device with CyanogenMod ROM to restart due to “missing fonts”.