Kurviger.de | Application | Blog | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Web tour planner - used to work but now website shows error! :-(

Day before yesterday I planned a day trip without any problems, but now I get errors about refresh problems or whatever. Even a newly planned route between two points is shown just shortly, but then there seems to be a “timeout” error, and the route is take away.

The website seems to request a manual “refresh” - for whatever reason. but even doing so does not yield another result.

As all other visited websites behave normal I do not think this behaviour relates to any change on my side. I should add, though, that I am presently in a foreign network that requires a login every time the comp is switched on or waken up again.

I am clueless what I should do about that.

Regards,
Petra

Hi Petra, can you show us a Screenshot from when that happens please? I’d like to see what your url, your waypoints and the error message looks like

1 Like

Sure: Here comes the screen after trying to import a tour consisting of about 21 points.

Normally I find the loaded tour centered and magnified to fit into the browser window, with the course of the tour shown as line.

If I center and magnify the obviously loaded route points the absence of the route course is obvious:
KurvigerFehler2

Trying to rebuild the tour by choosing another routing option (extra curvy instead of curvy, e.g.) reproduces the same error message as shown in my last post. And, of course no routing course.

1 Like

Hmm, very interesting, that does indeed look like some kind of broken API request to Kurviger, almost like your connection allows traffic to Kurviger itself but not to some scripts or backend resources it needs… :thinking:

Did you try another browser? I see that you have an adblocker installed, could you disable it for a second and refresh the page? Same goes for any scriptblocker, if you have one. That’s just for testing, it shouldn’t be a problem, but we need to rule it out as a cause real quick

Also: let’s do one more check to see that the route is definitely not the culprit. Could you post the link to the route from the screenshot here please, so that I can click on it and test it here?

I just disabled the adblocker for kurviger, and this seemed to produce the requested tour with course - but just for a second. Another (automatic) refresh reproduced an error and even eliminated the route points from the left list, and left the browser window “virginal”. I seem to remember to have encountered this behaviour once before some hours ago.

Another observation: I had to be “offline” myself (not the computer!) for sanitary reasons just before, and returning to the comp showed the route as expected. My further observations as described above were made after this (as I hoped you already had changed something and wanted to test again).

Here is the URL for the tour: https://kurviger.de/?point=51.49536%2C10.25208&point=51.50861%2C10.29108&point=51.50703%2C10.304&point=51.49055%2C10.41924&point=51.49424%2C10.44188&point=51.49685%2C10.44319&point=51.53111%2C10.48491&point=51.53326%2C10.518&point=51.48211%2C10.49651&point=51.44964%2C10.57171&point=51.45854%2C10.62946&point=51.45347%2C10.65562&point=51.41103%2C10.76717&point=51.35391%2C10.92364&point=51.39135%2C11.04385&point=51.35435%2C11.09639&point=51.3543%2C11.10673&point=51.42951%2C11.04409&point=51.47735%2C11.08507&point=51.4838%2C11.0948&point=51.5371%2C11.05539&point=51.58591%2C11.068&point=51.59266%2C11.04582&point=51.59108%2C11.033&point=51.61346%2C10.95092&point=51.62171%2C10.94667&point=51.62808%2C10.93461&point=51.69077%2C10.85267&point=51.58554%2C10.7854&point=51.57368%2C10.78692&point=51.56059%2C10.76915&point=51.59408%2C10.60984&point=51.60464%2C10.46326&point=51.59596%2C10.45779&point=51.53759%2C10.35487&point=51.53164%2C10.34095&point=51.52317%2C10.33192&point=51.51582%2C10.26085&locale=en&vehicle=motorcycle&weighting=curvature&additional_weighting=&ch.disable=true&use_miles=false&elevation=true&document_title=OstharzUndKyff.itn&layer=OpenStreetMap%20DE%20(FAU)

But I had this tour available, as anticipated, before, and my observation holds for other, previous tours as well. Of course I gave some of the formerly designed ones a try to rule out any recent procedural fault cause just by me. :slight_smile:

W/r/to your question about another browser: I don’t even have another one on my system. :slight_smile:

Just for the records: I use Firefox 67.0.4 (64-Bit) on Ubuntu 16.04

Another interesting detail, as I just tried to define a new, super-simple route into the present vicinity: A right-click into the map, to define an end point of the two-point tour, showed a very unexpected design of the appearing box, as shown in the following browser screenshot. Perhaps this gives you some idea:

Wow yeah ok there is most definitely some css or some other resources not loading. I’m out of my depth here (I’m not a developer for kurviger) and we’ll have to wait and see if @boldtrn finds some time to check this out.

In the meantime I truly hope you can get by with another computer or the kurviger app for Smartphones

Thanks for providing all the additional information @Petra-Kathi. I can’t reproduce the issue, is it still happening for you?

You are using some browser plugins like Adblock and Ghostery, these can sometime create issues. I tested the route you posted above in Firefox 67.0.4 with Adblock on Ubuntu and could not verify that behavior.

To me, it seems like that, either your Browser/Router or our security gateway denied permission to access to the route calculation and translation service (that’s why you saw these weird names like web.set_start). Are you using a new VPN or other anonymization software? We do have a security engine in front of our servers that checks if your request is likely to be an attack. If you are on a VPN, it might be that someone else on that VPN is currently doing anything malicious and you might share the same IP range, due to that your requests might be classified as malicious. There are some other anonymization techniques typically used by malicious attackers that might lead to incorrectly classifying your requests as malicious. It’s hard to tell to be honest :slight_smile:. I double checked our triggered firewall rules yesterday and tried to fine tune this a bit, but without knowing the reason why you have been blocked, it’s hard to tell (or if it even was the firewall).

3 Likes

BTW: I am not sure if you were using a VPN, but this blog is definitely worth reading if you are:

The blog in general is highly recommended, but quite technical :slight_smile:.

2 Likes

Just a short notice: The Kurviger website works again for me. Don’t know what has changed - at least nothing on my side I could have influenced.

As you have asked: I am presently attending a motor bike gatherin in a conference site. It features a WLAN access by the HOTSPLOTS system, where you have to log in anew everytime you switch on the comp or re-enter the range with your smartphone. I am not informed about the internals beyond this short information.

If Robin has tinkered in the background: Thank you very much!! My remaining three motor bike tours are safe to ride now! :slight_smile:

Cheers,
Petra

1 Like

Ah yes, that could already be the reason :slight_smile:. Thanks for reporting the issue. Please let us if the issue reappears.

Enjoy the motorbike gathering!

1 Like

Hi Robin,

yes, I did enjoy the gathering, even though the temperatures were wayyy up.

The issue did not reappear in its malevolent version (no tour planning possible; tour not shown) but I got warnings several times that the routing would be very slow (which was not really true, at least in my notion). Same did show up yesterday when I routed the web traffic on the notebook through my 4G smartphone.

But I am still curious if you did change anything in the web service? :slight_smile:

Kind regards and thanks for the help, even if only psychological to overcome the frustration,

Petra

I fine tuned 2 firewall rules that might have been triggered by the HOTSPLOTS system. So this might have changed something. But it’s really hard to know if this was the reason.

Great to hear that the issue seems to be resolved. Please let us know if there are any issues!

1 Like