Kurviger.de | Application | Blog | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Text to speech does not work well

I have problems with the audio instructions. As I have my smartphone in my pocket, I use the audio instrucitons over bluetooth to my intercom. The problem is, that I also use a music app on my phone to have music streamed over bluetooth and the volume of the instructions from kurviger is not loud enough to be heard over the music.

I also tried to use the telefone stream for the audio in kurviger. Unfortunately that does not work very well. It is partially cut off and the delay function does not work eiuther. I use the same in Calimoto and there it works perfectly.

The function to amplify the text to speech volume does not do anything to the volume. So I have 3 options:
1: Use Calimoto
2: Do not stream music while navigating
3: find a way to get the voic instructions on kurviger to work like in Calimoto. (preferred option)

Can anyone help me with this task?

There are many options in app “Settings | Voice guidance” to test:
(as each pair of phone + bluetooth works differently)

  • Voice guidance output
  • Prepare audio connection (avoid cut instructions)
  • Voice volume (use system or your setting)
  • Pause music (instead of fade playback)

Have you selected Google Text-to-Speech in Android settings?
Google TTS has extra options, like “Amplify speech volume”.

Yes, I have selected the ampliefy function, but that does nothing. Text to speech is way lower volume than the music stream. Would be great to have the option to adjust the volume for text to speech like the volome of other sources. But I think that is an Android problem.

I also played around with the different voice settings in the kurviger app.
It is not a problem of the bluetooth connection, as it also makes the same problems, when using the audio directly from the phone.

The only thing that keeps me from using kurviger over Calimoto is the audio problem. I really tried every possible setting, but never had any success.

In Calimoto the only good solution is to use the telefone stream for the audio of the app and that works very well there. So I thought it must be the same in kurviger. Unfortunately that does not work very well. Text is cut off and if I use the prepare audio function it waits for the time selected and then starts talking, but the music comes back prior the voice of the kurviger app is over. At least that is how I remember it. I am not sure about this. Have to try it out again, but any way, it does not work well.

Have you played with app “Settings | Voice guidance | Voice volume” option?
It has default system volume, you can change it for the selected audio output.

So, I have now tried everything I can. My results:
It works well without bluetooth, when I set the audio to use telefone stream. Unfortunately when I use bluetooth, the first part of the message is played on the speaker of the phone. After a short time, it then streams the rest of the message over bluetooth to my intercom.
Using the prepare audio function does not help, because then it randomly just keeps on playing the music and does not play the audio of the kurviger app.

When I use Calimoto I have to setup using the telefone channel for the audio and there it works great with my bluetooth interom. So I do not understand, why it does not work the same way with kurviger.

When I use the music channel for the app, the volume of the voice of the text to speech is far beyond the music, even though amplify is checked in the TTS settings.

Using the notification channel leads to no audio of the voice. No idea where I can setup the volume of the notification channel.

Playing around with the voice volume option does not help too.

There are 2 possible solutions.
1: getting the use of the telefone channel to work, like it does in Calimoto. Unfortunately that is not a task I can do and I guess that is not an easy task for you too.
2: finding a way to setup the TTS volume higher than it is with the amplify option selected or find another TTS app that has this option available. I wonder why google does not provide a slider for the volume of TTS.

FYI: I use a Xiaomi Redmi Note 5 phone and the Lexin B4FM intercom.

What could also help is an app, that allows volume controll for specific apps. Then I could set the volume for kurviger high and the volume for te music app low.

BTW, I just testet my bluetooth in ear phones and got the same results like with the Lexin intercom.

This is also possible in Kurviger. You can select music, notification or telephone channel. And adaptation of the volume of each channel isn’t this a standard android feature? On Samsung devices this works fine. Maybe this China bluetooth device is not the best. I have no problems with Sena headsets. With Sena 20S, 20S Evo or 30K (and I guess the 50X devices also work the same) you can choose between automatic volume adaptation via sensor or switch to manual mode and then you can adjust each channel manually via control dial. Best is from my point of view the Sena 20S or 20S Evo, an older device with the ability to update to the latest firmware. This has 2 separate bluetooth chips. With this you can talk to the colleague on the other bike and hear music and navigation instructions in parallel. The Kurviger settings like pause music oder just turn down on voice instructions or phone calls work perfect.

1 Like

It’s a while since my last post. After having given up on that topic, I now found out, that it suddenly works.
The telefon channel setting did never work and still does not. Now I use the normal media stream setting and for some unknown reason it works. I listen to music at a given volume and when kurviger starts to say something the volume of the misic raises a bit an so does the volume of teh kurviger announcement, but that from kurviger is a bit louder than the music. Just like it should be. I do not know what changed so this works now, but I am happy with it. Hopefully it keeps on working.

You can also try the “Settings | Voice guidance | Pause music”.

Pause Music does nothing. What music should be paused? How does kurviger pause music? How does it know which audio stream to pause? Maybe when I understand how kurviger does it, I could try several settings to get it working.
I use this app to listen to radio stations:

If you think it is the fault of the app, do you have any recommendations for a good app?
I cannot use the built in FM radio of my intercomm, because the receiver sucks.

I think that app uses the same audio stream as kurviger when I set it to use “wie Medien/Musik”.
My first tries a few months ago did not get me a good result. The audio from the TTS was way lower in volume than the audio from the radio app. Now, and I do not know why, it is a bit different. The audio is about the sam and when I set the volume for the radio app lower than max. and set the volume for the speech in kurviger to 100%, it raises the volume for both and the volume is about the same, so I can hear what the navi says and I get prepared to listen closer, whenever the volume raises. So this is absolutely ok for me. I am happy with tha. The option “notification” does not do anything better and the option “telephone stream” does not work very well. Teh first part of the text is cut off in this case.

This is handled by Android. The option simply turns on / off the “ducking”.

Copying from Android documentation:

“Used to indicate a temporary request of audio focus, anticipated to last a short amount of time, and where it is acceptable for other audio applications to keep playing after having lowered their output level (also referred to as “ducking”). Examples of temporary changes are the playback of driving directions where playback of music in the background is acceptable.”

Thanks. That was helpfull. It is the fault of the radio app. When I use Amazon Music app, it works fine. Now I just have to find a radio app, that works too.

Now I tested several radio apps and every single one of them worked well with kurviger. I can check pause audio and it goes silent and I can uncheck it and it just turns the volume level of the radio app down, which I prefere.
Seems that I have originally chosen the only radio app that does not work with this feature. Spent so much time to find a solution and it was that simple.
I am very happy now.

1 Like