Skip waypoints deactivated with BRouter

As far as I can say from yesterdays tour, the strict navigation is working. So far so :+1:. I just have a question. I had the effect that I wanted to skip waypoints, but it didn’t work because the skip button was deactivated.

Can it be because the brouter calculation was active because there was no internet connection? But also with brouter calculation active, it should be possible to skip waypoints, shouldn’t it?

Thanks for testing, very nice news!

Skip waypoint button is disabled when route does not recognize any waypoints ahead to skip them.

Your route seems to have been calculated with BRouter.
See my comment elsewhere:

Note that BRouter does not return via points in route instructions.
i.e. BRouter routes know nothing for via points, only start + end.

Clarification: Kurviger and GraphHopper work in a much more correct way.
They return instructions for waypoints too, so the route can know via points.

Routers must return instructions for all waypoint types: via + shaping points.

It’s app’s responsibility how to filter them, show all those instructions to user or not.

It will be solved in:

Should be solved in Kurviger 1.13.6 (Beta).

Solved in Kurviger 1.13.13.