Skip waypoint and recalculate Route Bug

Hi all,

discovered a bug when beeing off-the-route or skipping waypoint. Normally when pressing on the direction bar a submenu opens for route re-calculation, voice response, auto-zoom and skip waypoint.

When using the button “skip next waypoint”, the next waypoint should be deleted and the route should be re-calculated automatically. This doesn’t happen any more even if internet connection is available. The result is just “missed route”… same happens when pressing the arrow in blue background which is shown when beeing off-route. Neither the re-calculation from Start nor from next waypoint is happing, the error message is just “missed route” (translated from German version). This worked in the past very good, but in the update this seems to fail now.

for me, this is working as expected.
Samsung S7
Android 8.0
Kurviger 1.8.1


1 Like

Sorry can you give more details for the conditions or workflow?
i.e. the route and user location

Cannot really confirm, as 1.8.1 seems working fine in all tests.

I use “no automatic re-calculation of the route” by default.

I have left the planned route, the navigation bars loses the content, the white arrow on blue background appears on the top, I press on the top left navigation bar and the menu appears where I press on “Überspringe nächsten Wegpunkt”, but nothing happens. Neither the next waypoint appears nor gets the route re-calculated.

Only the message appears “Route verpasst” (missed route)

Also when I press on the white arrow where I have the option in the sub-menu to recalculate the route from the beginning or the next waypoint doesn’t work. The same message appears “Route verpasst”.

I also use the version 1.8.1. My phone is a Samsung Galaxy S8+ and I use offline maps.

I can simulate this behaviour on every trip, independent where I drive

Thanks for the extra details.

A bit difficult to understand without a kurviger route file while the images are captured, so to see the full route and what happens on map at that time.

In 2nd image are there any via points in route to skip? Because if there are only the Start and End waypoints, then there is none waypoint to skip, a route always has a start and end.

Also in both 2nd and 3rd images the start waypoint is already on user location, not on the route line. How did that happen, after the mentioned actions - so they actually worked?
Then probably - for whatever reason - that route request could not be done on the server.

@Tom, if you try to create a new route on the phone, would that work?
Is it possible to search via the search button of Kurviger?
Is Internet connection working? Can you e.g. search on google?


sorry can’t post fully the route. But it also happened on other imported routes (stored locally and imported). the route where this happened again, contains Start and End Point and additional 5 waypoints. In the middle after waypoint 3 I decided not to follow the planned route, but took a complete different one, so I wanted to skip next waypoint 2 times, but as told, it didn’t work and there was internet connection, you see that even in the screenshots on the top 4G with 2 bars should be enough. When there is no internet connection in the past Kurviger placed the error message “no internet connection” or something like this and not “Route verpasst” (“missed route”). Isn’t it? If not I guess that would be better as the message “route missed” when the re-calculation fails.

When using the function to recalculate the route from the Start (option 1) or from next waypoint in the submenu, isn’t this exactly what Kurviger usually does? It places a manuell new starting point and start recalcution, so the new start point is set, but the recalculation fails or doesn’t start. This must the program step that fails I guess. Even if skipping next waypoint too often, shouldn’t the fallback then be to calculate the route to the destination? At least this didn’t happen, nothing was calculated, even not a route to the destination.

could be, but I don’t know this reason, have no clue

At least I thought so and the device showed 4G with 2 bars at this time, but when I am now trying to do this at home, then it seems to work as expected.

Mabe the internet connection was not strong enough as I was on my route? This would be my only explanation why it is now working when using a 100 MBit line.

Maybe this shows that any kind of offline recalculation to at least the next waypoint (not necessarily the complete route and also without kurviger algorithm) would be better than nothing. Sure this is moaning at high level and I would find a way to the destination, even in the middle of nowhere, but I have to stop and play around on the device, possibly use another app, but this is something I would like to avoid, because I don’t like it.

Let’s see when it happens next time again, maybe I can then give better information in the future.

Precisely my thoughts and I already expressed my proposal in the relevant topic, without receiving any answers. :slightly_frowning_face:

I can start working on that after GPS logging. Obviously an offline solution won’t have (for now) the Kurviger algorithm (more a fastest route).

We can either provide offline graphs in Kurviger server or you can create them with desktop Cruiser.

For anyone interested we can continue the offline routing discussion there:

Mabye I missed that topic (I was only aware of this one). But as I already mentioned: I would prefer an offline routing solution integrated in the Kurviger app (even without all the special algorithms) than being forced to switch to another app in some situations (like I do until now with Sygic, which of cause also doesn’t provide special routing options fpr bikers).

I’m really, really glad to hear that! :hugs:

Both ways would be OK for me, but I think most people would prefer the more comfortable version of providing prebuilt graphs on the Kurviger server.

Actually it’s the same topic. :slightly_smiling_face:
Please let’s continue offline routing discussion there.