Kurviger.de | Application | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Route width and AutoZoomLevel

implemented
#1

Question:
Is there a reason why the highest AutoZoom level in the navigation menu is limited to 18 and why the route widh in the route calculation menu is limited to 200%?

I would even prefer up to 30 for the highest AutoZoom level and up to 500% for the route width if technically possible. The default values can be lower, but why limit these ranges?

#2

Most maps zoom until level 18, though we allow app up to level 20.

Current max route width and auto zoom are just sane defaults.
We can change them in sane limits, if there is sufficient need.

#3

Could you maybe post a screenshot? What device are you using? On my device z20 results in a map area of about 30x50m.

#4

Not easy to simulate at the moment, since I have no time to drive… that’s about the size of… at max 200% width



I use a Galaxy S8+ in middle-size resolution 2220x1080

#5

Thanks for the screenshot. Is this the maximum zoom level? So you can’t zoom in any more?

#6

Max zoom in app is much much larger, scale bar will show “10 m” then!

#7

No it is not the max zoom level in overview mode, I just try to simulate how it looks while I drive having the AutoZoomLevel in AutoZoom mode and the highest level of AutoZomm set at 18 (not more is possible) and the route width at 200% (not more is possible) That’s the reason why I would need to use 30 as the highest AutoZoom level and up to 500% as route width. I would like to use a broader route width while I drive. I know that it is possible to zoom in more in overview mode, but I need the broader “routing line” while beeing in navigation mode. Hopefully described better now… can’t answer further till tomorrow…

#8

Such large zoom levels are not usable. Anyone ever handled a map at such scale? Even indoor foot navigation uses much more conservative limits.

We can think if it’s useful to increase max auto zoom within map limits and max route width without route becomes so thick that any curves disappear.

#9

This is sufficient. Even if the limit is at 30, it can be adjusted to 18, just according to indiviual needs.

#10

Like mentioned above, map’s max zoom limit is 20, there are no plans to change that as there is no actual use for anything more.

#11

I meant the navigation menu AutoZoomLevel. Isn’t this at 18 max at the moment? Can this be extended?

#12

That could be increased to map’s max zoom level 20.

#13

You would need to increase the min zoom level. If you set the min and max zoom to 18, it will be fixed to 18. We set 18 as max autozoom level because this is already very close. Could you please check how it looks for a fixed zoom of 18?

#14

It looks like the screenshot that I have already posted. It is ok, but not more. For me 18 is not wide enough. If you switch your device to 2220 x 1080 pixels and pass the age of 50 for several years, then you know what I am talking about… :slight_smile:

I have eagle eyes at far distance, but not at near distance any more… any human beeing passing the 45 will probably agree… :slight_smile:

It is call presbyopia…

#15

I have a full hd device with 1920 x 1080, this shouldn’t be too different from your device. If I go to zoom level 18 it looks like this:

It’s already very close. You can try to go to the menu, tools, go to coordinates, and then change the slider to z18. This should be a lot closer than your posted screenshot.

To me it seems like that you put the max zoom level to 18, but still have the min zoom at maybe 15?

#16

You are a nonbeliever… :upside_down_face:
my setting is min=18 and max=18 and this is too small for me. If only 20 is possible, then please make 20, but I would prefer 30.

This is it actually at min=max=18 (can live with it, but would prefer more)

#17

I am just wondering why your device behaves so differently. I have tested Kurviger on many different devices and I have never seen z18 to be that far away. z18 should look like my screenshot above.

Your screenshot looks like you would be using the follow route mode and not actually navigation (no navigation panels). Autozoom only triggers when you actually press the navigation button. Or maybe if you had used navigation before, you were off the route and the off route zoom level triggered?

z30 should be an area of <1x1m stretched on the whole screen.

Have you actually tried this:

#18

Zoom level can be tested precisely via the menu Tools | Go to.

When scale bar shows 1 km, then zoom level is approximately 13.
When scale bar shows 500 m, then zoom level is approximately 14.

Here is zoom 18 on a 1440 x 2880 pixels screen (scale bar 20 m):

1 Like
#19

Discussion is probably irrelevant to zoom level and should focus more on route width?

#20

Maybe we should also clarify what you mean with follow route mode (for me this is the navigation mode while riding) and yes, I mean this mode… and the buttons disappear because I have ticked this option in the application menu… In the Go to Coordinates function I can use 20 as Zoom Level, but in the Settings --> Navigation menu I can set only 18 as highest AutoZoomLevel. Why can’t I set 20 here?

This would then probably meet my wishes. 30 is maybe too much, but how can I know this before trying? And how can try this before this feature is available?