Problems with routing - iPad, iPhone

Hi guys,

we do have several notes about not working routing with iOS devices, esp. when planing with a mobile device, such as iPad und iPhone - no problems with Mac. One of the problems is that it is not possible to add additional waypoints, once a start and end is set.

Any idea? We have collected the items here: Probleme bei Routenplaner - Kurviger (bei Motorradfreizeit eingebunden) - Motorrad-Portal und Community

Thanks a lot in advance.
Cheers Michael

Took the screenshot from your forum to declare my opinion:

When there are visible one or two of the UP-/DOWN-Arrow-buttons (A) to open/close the sidebar (B) then currently it is not possible in the waypoint list to add an additional waypoint between existing waypoints.

For me this happens e.g. at the smartphone in portrait or when the browser is very narrow.

Took the notification and screenshot of the issue from your forum:

am ipad, ios 16.3.1. keine zwischenziele-+ bleibt dunkelgrau


I don’t know, why for the ipad, ios 16.3.1 the “+” in the toolbar is marked in darkgrey and without function.
Don’t have an iPad to test. But perhaps it is caused by browser?

Hi Walter,

thanks for coming back - tried sevreal settings:

Macbook Air - Browser: Opera, Firefox, Safari - NO problems, working fine
iPad / iPhone - Browser: Chrome and Safari - known issues as described before

Seems to be a problem with the “mobile” system of iOS.

Cheers Michael

Perhaps @boldtrn can give more info about common changes in the sidebar and their possibilities/inpossibilities in mobile systems (smartphone, tablet) in portrait/landscape and/or narrow browsers (low width, e.g. < 600 px). Or if this is really an issue with iOS mobile systems.

I can verify this issue, the + button seems broken on iOS in all browsers (iOS uses Webkit, which is the basis of the Safari browser for all browsers). We will investigate this issue and hopefully fix this soon.

I am not sure about the other issues, as I can’t reproduce them locally on an iPhone. I don’t have an iPad for testing.

We have some info about typical issues in our documentation. So one idea is that some people might have installed some privacy plugins that limit the browsers ability. Some of these plugins might even work like a VPN and filter certain network requests (which could lead to the map being gray).

For some reason, Apple is updating Safari as part of the OS, so you can’t update Safari without updating your OS. This is true for macOS, I am not 100% sure about iOS, but I wouldn’t be surprised. Some of the comments in the Motorradfreizeit forum mention they are using an older iOS version. While I don’t know if updating the version, will fix the issue, it could, I tested with iOS 16.3.

More backstory:
Unfortunately Safari in general, but especially mobile Safari is becoming more and more troublesome over the last years. Since Apple is locking in users on iOS, users can’t use a different browser engine. This is really an issue and is planned to be banned in the EU by May 2023, see the Digital Markets Act, which will force Apple loosen up their restrictions (hopefully :pray:).

And since you can’t use a different browser engine on iOS, installing a different browser won’t give you access to better website behaviour, your browser will just appear differently and have a different name :frowning:.

Ok sorry, my reply ended up, being a bit of an Apple rant - sorry about that.

Thank you, Robin!
Sounds pretty clear to me.

Cheers Michael

We have identified the issue regarding the + button and fixed it. I hope this works for iPads as well? It works fine on iPhone now.