Problem with the export of a route "Could not export! Status: 400"

I receive the following error message if i export a route. “Could not export! Status: 400”

Know somebody a solution about that?


1 Like

Hello, unfortunately I’ve the same issue.

Same problem with me.
It’s not the browser, because I tried Brave, Firefox, Opera and Microsoft Edge, always with the error: “Could not export! Status: 400”.

BR Rainer

Hi all, I cannot reproduce this on the website currently. I tried with the exact settings that can be seen in @SimOn 's screenshot, even with quite a long route, but everything seems to work fine. Maybe there was a temporary server hickup? Can you confirm whether this is still happening to you all?

Hi Patrick,
no the problem still exists.
Which browser did you use?
By the way, I have cleared the browser cache and the cockies.

Hello Patrick,
the problem still exist.
After a lot of tests, i can reproduce the error.
With this tour its works: Kurviger
With this tour not: Kurviger
I try it with Edge and FF, the same results.

Alejandro is right, problem still exists. And, it is not browser- related. It is also not user- related. I logged out myself and tried as a “unknown”- user. The same …

Hi Patrick,
The problem is only on the computer.
If I plan the route on the computer and then export it via the android app, it works.

Hallo Zusammen,
in IOS funktioniert es auch nicht.

It seems like a problem with the request to the API.

scheme https
filename /route
point […]
0 55.140219,-2.261583
1 55.01115,-1.82293
2 55.0567,-1.68814
3 55.07662,-1.67179
4 55.06622,-1.63567
5 55.06983,-1.60214
6 55.02742,-1.50482
7 54.99335,-1.45445
pname.1 Stamfordham Road
shaping.1 true
pname.2 Continue
shaping.2 true
shaping.3 true
shaping.4 true
shaping.5 true
pname.6 New York Road, A191
shaping.6 true
pname.7 Arrive at destination
type gpx
key 970c7e2c-fd12-4395-ace0-1457fdaf4a14
gpx.route true
gpx.track false
gpx.waypoints false
gpx.track_name Schottland20B GUS M
gpx.additional_waypoints 3
gpx.file_format TomTom95RouteFormat
gpx.alternative_route.path_index 0
app.type web
gpx.waypoint_names false
gpx.shaping_points false
elevation true
details […]
0 route_information
1 max_speed
2 street_name
avoid_toll_roads true
avoid_unpaved_roads true
document_title Schottland20B GUS M
route_collection_id iaB8vKU1iCO0xx3lz8IE
route_id gm69UViil19AlBSYxRog



Bad Request

Hello Patrick,
i have found the problem.

Sometimes the website if you press export they create a wrong GET String to the API.
In the String sometimes is missing the following parameter: weighting=curvaturefastest

Wrong String: elevation=true&details=route_information
Correct String: elevation=true&weighting=curvaturefastest&details=route_information

Copy the API String and added the missing Value weighting=curvaturefastest


Same problem here. Tried multiple routes
@Alejandro_M can you explain how to use your workaround?
Edit: inspired by the 2 routes you provided and looked for the differences and the suggested weighting=curvaturefastest I saw the difference between the 2 routes.
One has the setting curvey roads, the other fastest. When you set the route calculation to fastest, the export works. Offcourse you might need to add some shaping points to maintain the route…

Hi, unfortunately same here, still can’t export this exact route.

Same problem here. Does not work with setting “curvy”, however fine withe setting “fast and curvy”.

@Venzent I run Inspect (Q) in FF to see whats happend. Under Network Analyse i can see the Get Request and it ist possible to copy the request for analyse and modify.

All planning models are working without curvy
In the curvy model the parameter weighting= xxx is missing

1 Like

I accidentally deleted my subscription. I unintentionally pressed the button.
How can the subscription be activated again?
After termination of the subscription, the data expression does not work. The following error message is displayed:
Could not export! Status: 400

Hi Tegali, this error has nothing to do with your subcription, we are already working on this problem and a hotfix will probably arrive later today :slight_smile:

1 Like

ja das ist die lösung. vielen dank :+1:

Thanks for reporting this issue and the detailed investigation @Alejandro_M :+1:. We have fixed the error and this should not happen anymore.

It can take a few hours until you see the update. Please make sure to click on load new version to use the version. You can speed up the process by using “Ctrl+Shift+R”.


Yep it works now! :smile: Thanks for fast response and fix :clap: :+1:

1 Like