Kurviger.de | Application | Blog | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Problem with charging my phone

Hi All,

I use the app on my motorbike, on my motorola G6plus phone.
I am a long time fan of the app and why anybody would still use a separate GPS device is beyond me.

Having said this, I do have a nagging issue with my phone not charging well using the USB port in my Honda Transalp 650.

Before I explain any further → I assume this is totally of topic or can I ask this here ?

I’m desperate to find a solution and I assume that all users use their phones like me so I can’t be the only one with this issue ?

thanks
best
Hans

Hans,
I had a similar problem with a Sony Z5. It was due to the USB plug and the too thin cable. After I bought a Quick Charge car charger (mine is from revolt) and a fast charging cable with a larger diameter (UGREEN with 20AWG) everything works fine.
VG Wolfgang

2 Likes

Does the Transalp have a USB-outlet or do you mean a USB-charging-adapter plugged into the 12V outlet. Many of those (cheap) USB-chargers do not deliver the current ratings they claim.

Another issue I had in the past, was that the charging adapter didn’t fit tight enough and lost contact from time to time.

See also:
here and here

This one is working for me

Use the App Ampere to check different cable. There are big difference between the cables.
Hope this can help.

3 Likes

Another solution is to buy a ruggedized phone: more protected from heat, rain, with a powerful battery, etc. and keep the usual phone to make calls, photos, etc.
In the long run the USB connectors are damaged, the camera with the footsteps is damaged, …
I use a 10,000 mAh one and I don’t need to plug it in all day;)

I did have the very same issue. My phone (rugged with a comparably large battery) consistently got discharged as it was used during the day. The reason is that the display is always on. My solution was to use a more powerful charger and a proper cable. Also, cables tend to wear off over time so need to be replaced occasionally. The charger I currently use is called Optimate O-108 and is connected directly to the battery. Before that I had tried one of those chargers, which directly plug into the bikes 12V socket (can"t remember which model it was) but had no luck with that.

Cheers,
Tom

The transalp is an old bike so originally it has neither a 12 volt outlet (cigarette lighter) or a USB port.
What they installed on it is something like this, with 2 ports, nothing special : snelbalie
The mecanic told me they always install this type, without issues.
The fit of the USB cable in the phone is ok, that is definitely not the issue.
My battery is just 3200mAH.
Thanks for the Ampere app tip, that is great advice, I will go for a ride soon and report what current I see.
As for replacing the USB outlet alltogether, maybe that is what I should let them do … a bit sad that I specifically explained my issue and they did not mention fast chargers or difference in charging capabilities between USB systems and just soldered/connected the one they always offer.
Otherwise I would have chosen the stronger type.

  • 4A ? Nice. So presumably the phone power electronics fail to compensate for the continu max brightness display on PLUS continu gps on power consumption.

Current Kurviger:
When navigating, the display stays on continuously with (mostly) maximum brightness. (+/-800mW)

What can be done to save energy @ navigation ? (Actually = none).

A. Most energy saving.

During most of the navigation the display is off .

  • At an instruction you get a display on sequence.
  • By proximity single wave sensor trigger or external control unit: Toggle between continuous display on or back to “auto”.

Because of the necessary device admin rights you get a lot of extra problems that neither users nor the developer (rightly) may prefer not to have.

B. A less energy saving alternative ?
@Devemux86
Can this be done or even do you eventually want to ?
Yes I know, this also means another extra setting menu :frowning:

When navigating, the display stays on continuously with minimum brightness. (+/- 200mW)

  • At an instruction you get a maximum (standard) brightness sequence.
  • By proximity single wave sensor trigger or external control unit: Toggle between max (standard) luminosity or back to “auto”.

Energy saving:
Minimal (turn) alerts = Minimal energy consumption.
(Mostly there is no need for Straight commands)

There are some discussions (no decision) to see:

If that beast really can deliver 4A, that should be more than enough.
I think anything that is able to deliver 2A should be sufficient.
Smartphone with running navigation typically needs ~1A.

1 Like

The link with the example was just to show what the device looks like :slight_smile: it’s not the exact one that they put on the transalp . Anyway, today I took a good look at my device and it states 5V/2A. I also went for a a ride , more than one hour and managed to juice the battery a a little bit during that time (kurviger app running most of the time) - as you can see on the Ampere app screenshots.


The mA was between 350 and 800, it seems to be different every time I stop riding (keep engine running) and check the app. Later back home on my 3A wall adapter the current is 2000mA or more and also very stable. (I conclude from this, that at least the cable is ok)

My phone consumes around 500 mA with full brightness, acccording to the ampere app.

Not sure what to conclude from all this ! :flushed:

When I go for a full day trip what typically happens is that the phone charges like this a little bit (which is fine for me) but after a while it stops charging and it gets to the point where it doesn’t even charge my phone when I switch it off.

This would be no option for me. I want to have the display at maximum brightness all the time and also no black screen while driving. As an additional option, yes that’s fine, but not by default.
If you use a usb device that delivers 3A at 12V you have no problem at all with power consumption. But most cheap devices only have 1,5 A at 12V and this is too less. With my Galaxy S9+ even 2,4A is too less. It has to be 3A.

1 Like

If you used the same cable, probably the cable is OK.

If you tried different cables, it might be that the charger on your bike is not strong enough. If it states 5V/2A but only provides 700mA then something might be odd.

This could be due to overheating. This can happen if the charger is not strong enough to keep your phone at 100% - this will create more heat. If you have your phone in a closed mount, you could try an open mount or maybe not closing the case 100%.

@Tom.
Of course I suggested this as an option only :wink: (See remark extra menu necessary)

Good (universal) power delivery over USB that is 100% compatible with your own phone type is not always that simple. See (google) USB power standards for the various USB bus types already in circulation.Some converters are so cheap that I can’t imagine it being something decent.
Good components for switching power supply converters bought separately are already more expensive.

I used the same cable yes. Next on my list is to try charging a friends phone on my bike and check the ampere app, if it shows the same low mA then a better USB charger is needed. I’m also curious what current his brand new Kawa will put into my phone :slight_smile:

As for overheating I thought about that, but looking at the battery temp in the screenshots, this looks ok to me. Also, while using the wall adapter, the battery gets even to 40 degrees. I have a safety cover that leaves the screen uncovered / not a full case. I will leave it aside next time and see what happens.

They probably mean two ports with 2A each right? 4A would be insane

That is super low, even my battery starter emergency pack can push out 1490ma