Navigation header information disappears

Last sunday on a Black Forest Route I noticed, that the information at the top of the navigation screen disappeeras and the fields became empty ("–").(pic 1).

This took at least 8 minutes.

I cleared the route and imported it again - no change.

I closed the app, started it again and only then the information came back.

What could be the reason?

1 Like

Did you try to double press on the navigation button? Did you use the “use orientation” option under settings? Could it be, that you were cruising in the wrong direction (sounds stupid, but it happened to me before as well :D). Any other ideas @devemux86?

a) No.
b) Yes.
c) YES …
but how to avoid this?

((BTW: I am just using the New Forum with my smartphone, whereas before I posted via pc - there are some minor differences like using “quotes” of posts, which seems to do not work, or the drop down menue of emoticons, which does not work well.))

I would recommend to double hit the navigation button in these cases. Otherwise it would be helpful to have a GPX track and the planned route to see if the same thing happens again if we replay the GPX track, this could help to narrow down the problem. But in general it is hard to tell with one-off situations without knowing what exactly happened. The orientation support is still in Beta because there could be some edge cases that break the navigation.

It worked for me. I quote by marking the text in a different message and once it’s marked there is a quote popup. Emoticons seem to work for me as well, could you explain what happened?

Hmm - impatient again … yes, now it works. :smile:

Emoticons:

With the 3 bars menue it works.
But if I start with a “:”, it looks like (see bottom of the screenshot)
:


the bottom of the list is cut (not so good to see in the screenshot).

It should look like this:

(((Hope you are not getting confused by the screenshot of the screenshot … :rofl:)))

THIS did not help - similar to clear the route and re-import it.
Since after restarting the app it worked again (without moving!) this seemed an internal issue of the app.

A bit difficult to understand from only the image, seems user location is not projected correctly on the route there.

In such cases would help greatly to have besides screenshots, also the route (gpx or kurviger), the position of the event and the enabled navigation options.
Then I could replay the event in my navigation simulator and debug the core variables to see what happens. :slightly_smiling_face:

Perhaps I can help you: :wink:

Recorded track:
2018-06-24-153223.gpx (1.1 MB)

Kurviger’s route:
20180624_174533.kurviger (1.9 KB)

THESE screenshots were taken within one minute before and after restarting the app:

The two last pics were taken before and after reloading the route - perhaps a hint for the direction problem Robin mentioned already.

Again: All 3 screenshots were taken without any move!!

2 Likes

Thanks that helps checking it!

And you had enabled the “Orientation support” navigation setting?
How about the “Kalman filter”, was it enabled?

Between 2nd and 3rd image, a rerouting happens?

Yes
Yes.
:wink:
Yes - cleared and reloaded the route.

I have the same problems. No infos at the top after rerouting but GPS is on and the vehicle marker is correct.
Where do I find the “Orientation support” in the navigation settings?

It’s now enabled and integrated in navigation process.

automatically?

Previously existed as beta option for users to test.
Now it’s enabled and works automatically with navigation.

1 Like

Hmmm - another occurence:

After leaving the road for about 100 m to have a short break, I wanted to see how far destination will be - but was disappointed because header information was gone (pic 1).

Then, after I got back near the road, information apperead again (pic 2).

Any explanation - for example because it was no legal road but only a lane between the fields?
Any work around for those situations?

@Uli_LH thanks for the reports!

The first examples above seem involved in corner cases with bearing, I’m looking to improve the algorithm variables there.

The last example seems normal? If get away from the route (e.g. 100m), this is considered “off route” situation and cannot navigate or provide instructions (1st image). When get close to route again the navigation resumes (2nd image).

1 Like

Ok, thx - then I obviously just exceeded the 100 m limit in this case … :wink:
was not aware of this limit, so good to know now! :+1:t2:

I had a similar situation on my tour. I tried to click several buttons, I restarted kurviger and I even rebooted my phone but it didn’t solve the problem. At some point later it worked again without doing anything. I also don’t have any screenshots and no gpx, in fact this wouldnt help as I couldnt tell exactly where it happened. I just remember that I was driving on the regular route, didn’t leave or did a u-turn or whatsoever.

I know this won’t help much for your investigations, but it seems to occur not so seldomly.