Kurviger.de | Application | Blog | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Kurviger 1.14.12 (Beta)

Kurviger 1.14.3 (Beta) is on Google Play (instructions):

- Map: symbol size option

You can change the size of map symbols.

Available in “Settings | Map | Symbols size”.

- Export: waypoint names and shaping points

Export waypoint names and shaping points with online route formats.

- Export: GPX (offline) shaping points

Export shaping points with GPX (offline) route format.

- Import: shaping points (GPX)

Import shaping points with GPX route format.

- Various improvements

2 posts were merged into an existing topic: App: Storage access framework

Hi devs.

Congrats! Via and Shaping point transfers by the gpx type tag available in the Kurviger app.
Before I unsuccesfully promoted this simple method by type in other app new idea forum section.
So now I already successfully tested such transfers by gpx using the latest (Beta) Kurviger app.

Although I was quietly hoping the use of type text Shape instead of Shaping.
To keep compatibility now must change my text suggestions and all my example files in that other app New Idea forum section ? Phew …
Or no, I won’t change it anymore. Some gpx extra fragmentation only a little annoying for optimal information exchange between apps, possibly nobody is concerned about that. :flushed:
The freedom gpx offers naturally contributes to fragmentation by dialects.

Kurviger 1.14.4 (Beta) is on Google Play (instructions):

- Various improvements

Kurviger 1.14.5 (Beta) is on Google Play (instructions):

- Various improvements

Perhaps I misunderstood, but I expected to see a difference in GPX depending on kind of waypoint (via point / shaping point).
I used a test route https://kurv.gr/znwGM and exported it to all available GPX formats - but I can not see a difference between Waypoint 1 (via) and waypoint 2/3 (shaping)
TstViaShaping (2).gpx (2,1 KB)
TstViaShaping.gpx (1,2 KB)
TstViaShaping (1).gpx (982 Bytes)

Can you also mention what format each GPX file is?

Did you check the “shaping points” in export dialog?

1 Like

Shame on me!
I will check, try again and give feedback! :confused:

With checking “Shaping points” in export dialog I see differences:

  • GPX and GPX offline: Tag ‘type’ is ‘via’ or ‘shaping’
  • Garmin: Tag ‘sym’ is ‘Flag, Blue’ or ‘Waypoint’

TstViaShaping.gpx (1,2 KB)
TstViaShapingOffline.gpx (1000 Bytes)
TstViaShapingGarmin.gpx (2,2 KB)

Thanks for the help!

1 Like

Probably the shaping points check box should be selected by default?


Just to be precise I have to correct:

  • GPX and GPX offline: Tag ‘type’ is ‘via’ or ‘shaping’
  • All exports: Tag ‘sym’ is ‘Flag, Blue’ or ‘Waypoint’

From my point of view : Yes.

1 Like

Did you find some error?

App exports internally / offline only the Kurviger and the GPX (offline) formats.

All other route formats are exported externally / online via the Kurviger server.
(and they should be the same)

No, no error - I think it is intentional that there is no ‘sym’ tag in the Garmin export.
There is just a finding concerning given names - they appear in offline export but do not appear in the online exports (GPX), but I am not sure if that is implemented already . Example with given names for start, waypoints and destination:

TstViaShapingNameGarmin.gpx (69,9 KB)
TstViaShapingName.gpx (68,6 KB)
TstViaShapingNameOffline.gpx (48,0 KB)

Waypoint 1 in GPX Exports:

<rtept lat="48.877174" lon="11.711955"><name>Waypoint 1</name><desc>Waypoint 1</desc><sym>Flag, Blue</sym><type>via</type></rtept>

<rtept lat="48.877174" lon="11.711955"><name>Waypoint 1</name><desc>Waypoint 1</desc><sym>Flag, Blue</sym>

<rtept lat="48.876854" lon="11.712254">
<name>Erster: Via</name>
<sym>Flag, Blue</sym>

Creating a route in app with waypoints names, they are exported even in online formats.

How did you make the test?

A post was merged into an existing topic: Website: Export Waypoint Names and Shaping Points

Hmmmmmm - I just did it again to document it - now it works, given names are in GPX.

Sorry - I can not reproduce it just now, will do further tries. I used the app v1.14.5 (checked version info in app before) for creating route and for all exports and thought last time I did it this way:

  1. Open link

-> Kurviger App opens, Waypoint 1 has name “Erster: Via”

  1. Routing / Export, format = “GPX (*.gpx)”, track=1, route=1, Shaping-Points=1, Additional waypoints = “many” -> press OK
    But: Names are in GPX :+1:

The comple history was nearly like this (I do not know every detail):

  • After creating the test route for my posts Kurviger 1.14.5 (Beta) and saved a .kurviger file
  • afterwards I did GPX exports in several formats without checking “shaping points” in export (fault!)
  • after reading your reply I opened kurviger again - I do not know any more if I opended my presiously exported kurviger file or if I opened the link in that post
  • afterwards I did GPX exports in several formats with checking “shaping points” in export
  • worked fine (shaping point infos were in GPX as described)-> write reply in kurviger forum
  • later on I opened kurviger again - do not know if I just opened kurviger and the route was still there, or if I opened route link or if I imported .kurviger file
  • Then I set the names of start, waypoints and destination.
  • Then I saved a new kurviger file
  • afterwards I did GPX exports in several formats with checking “shaping points” in export
  • I saw that the name was missing in online formats as described in Kurviger 1.14.5 (Beta)

I am sorry - I can not reproduce it. I also remeber that I did some changes of language setting between english and german - perhaps I forgot an restart. I tried some language changes in both directions right now, with and without restart, but names are always in GPX export :+1:

My usual export orde for this export tests was

  1. GPX(*.gpx)
  2. GPX (offline)(*.gpx)
  3. Garmin ShapingPoint GPX(*.gpx)

I hope, you can see in my exported GPX above that I used the 3 formats of exporting.

Sorry - I give up for today, I will watch it and give feedback, if problem occurs again.

1 Like

Kurviger 1.14.6 (Beta) is on Google Play (instructions):

- App: requires Android 5.0 and up

- Various improvements

Kurviger 1.14.7 (Beta) is on Google Play (instructions):

- Various improvements