K3 won't start on Carpe Iter

Thank you, Robin,
But playstore shows a message that the product is not compatible with the device.

Ok, thanks for checking, I did some more digging, so it seems Carpe Iter has not made their Webview Updatable.

I did some research, here are links with more info, if you are interested, it’s very techy but I figured I will add this for reference.


I do have the same issue with a Carpe Iter Pad running Android 9.
No Add blocker, Chrome is up to date and all other apps running without any issues.
The old Kurviger Pro app also worked fine.

This is a known issue for Carpe Iter unfortunately, I moved your thread to the correct topci.

I’m having the same issue on an Samsung Active Tab 2 that I just purchased, it is running Android 9 and the apps are all up to date. I think it is very similar to the Carpe Iter tablet. I get the same error on other websites, like trying to access taskernet.

Samsung usually has an updatable Webview, I would be surprised if it would be the same issue, I would recommend to first try other options, for example:


Very interesting, thank you. I’m learning something new every day.

1 Like

I tried the update and it started working.

1 Like

Merci beaucoup de l’info sur Android 5 minimum pour utiliser kurviger 3, désolé mais avec deux smartphones l’apk ne tourne pas :
-Likebook Mars androïd 8.1.0 message kurviger 3.0.7 « uncaught syntax error : unexpected token ‘.’» erreur de syntaxe non interceptée : token ‘.’ inattendu
-Nomu Android 6.0.1 même message mais curvy 2.2.28 fonctionne correctement. Toute les applications sont a jour, chrome aussi.

Je souhaite utiliser mon ancien smartphone Nomu (android 6.0.1) sur ma honda goldwing car les jours de pluie ne lui posent aucun problème, il est étanche. Merci de réparer kurviger 3.0.7 pour android 6 et suivant s’il vous plait.

(Aucun problème de fonctionnement avec mes machines récentes Wiko et huawei sous Android 8.0.)

Just to clarify Kurviger v3 should work fine on Android 6 devices, if you can update the Webview. Most device manufacturers make their Webview implementation updatable. You don’t need the latest webview, 2-3 years old version should still work (latest version is always recommended). The official documentation (linked above) recommend to make the Webview updatable.

I don’t know why some manufacturers don’t do this and there is unfortunately no way to support webviews that are that old. So for now there is nothing we can do on our end, I am sorry. Webview is a hard requirement for Kurviger v3.

You can try the tips I have posted above, maybe they work on your device.

Merci, j’ai fait cela sur mon nomu et cela a fonctionné sauf que en mode test de navigation au bout de quelques kilomètres il n’y a plus de carte ! Juste le trait bleu de la route avec les virages.

Sur ma likebook mars j’ai installé Android webview mais ça n’a rien changé.

Merci encore.

I am happy that this helped :+1:. Are you connected to the internet? If there is no map loaded, this can be related to an internet issue. If this issues continues, could you please create a separate topic for this, as this has nothing to do with Carpe Iter or the Webview :slight_smile:

Ok merci beaucoup

Good news for CI-Pad users. Carpe iter will publish a hot fix for Kurviger as well as a rom update later this year. Got this reply to my ticket:

Hello Peter,

We are aware of the problem - there is a completely new Kurviger app released recently. We will be releasing a hot-fix guide in couple days (already tested procedure) and ROM update later this year to deal with that (and a few other) issues. We just need a few more days to also finish Controller app update so that our controllers work with the new Kurviger app (it is really a completely new app, not a simple update).

Please feel free to post a copy of this message on the Kurviger forum.

We are sorry for the trouble.

Best regards,



Workaround here: Install the magisk module GitHub - F3FFO/Open-Webview: A magisk module created to replace system webview and then use the „bromite webview“

Then kurviger3 will work on the CI Pad.

1 Like

Works perfectly, thanks!
For those wanting to install: The CI V4/V4b running the JKR Roms are already rooted. magisk app is hidden tho, you can find it in settings app list, start it from there and install the bromite module.

1 Like

Ich bin in den Bergen in der Türkei und möchte die D915 mit ein paar Extras fahren und bin daher auf eine exakte Navigation angewiesen.

Bisher habe ich Kurviger Pro auf meinem Carpe Iter Tab auf Android 9 (auf dem neusten Stand) verwendet. Bei der Anpassung der Route mit Kurzlink wurde dies nicht übernommen (alle möglichen Kombinationen versucht, GPX geht schon gar nicht) oder hat zwei Routen in Blau und Grau (verwirrend) angegeben. Auf dem Handy (Anrdoid 12) hat dies auf Anhieb problemlos funktioniert. Natürlich habe ich die üblichen Sachen wie Neustart, Cache leeren und Speicher leeren versucht.

Bei der Neuinstallation bin ich dann stecken geblieben. Kurviger Pro gibt es nicht mehr. Und bei der Installation der neuen Version bleibt Kurviger mit “Uncaught SyntaxError: Unexpected token” hängen.

Daher meine Fragen:
a) Wie kann ich Kurviger Pro erneut installieren?
b) Läuft die aktuelle Version unter Android 9 (das grundsätzlich tolle Carpe Iter Tab gibt nicht mehr her)?
c) Wie kann ich die Fehlermeldung beseitigen?

Ganz herzlichen für jede Hilfe! Für eine erfolgreichen Tipp sende ich Dir EUR 30 per Paypal!

Siehe unsere Doku hier: Aktuelle und bisherige Versionen der Kurviger App [Kurviger Knowledgebase]

Ich habe deinen Beitrag in den passenden Thread verschoben, das ist leider ein bekanntes Problem bei Carpe Iter, es gibt aber einen Workaround vom Hersteller (siehe weiter oben).

Super, hat funktioniert - sende mir Deine PayPal Adresse an stefan.wieser@wieser-ag.ch.

Danke für dein Angebot, wir haben sogar ein bisschen Dokumentation dazu wie du uns unterstützen kannst :slight_smile: - Du willst Kurviger unterstützen oder mitmachen? [Kurviger Knowledgebase]