K3 won't start on Carpe Iter

Kurviger 3 does not start on my carpe iter (Android 9)
Screen: “stuck while loading”
Changed default Browser from Firefox to Chrome, did not help.
Any idea?

For an Android device you need to download the K3 App as far as I know. Or do you get the message while trying to access ‘kurviger.de’ in the browser on your carpe iter?

Thank you for the advice. I know that I need the K3 APP. The message is shown while the app is going to start and does not go away, nothing else happens.
Doing just the same on my Android (also version 9) phone works fine.

I rebooted the device several times and uninstalled and reinstalled the K3 APP. I worked through all the tips on the trouble shooting page. I had not installed chrome before (I normally use Firefox) and made a fresh install and made it the default Browser. Chrome version 108.0.5359. Kurviger pro and 2 work fine, as well as my other apps, e.g. a test install of locus. I also made sure that no other apps are running.
The only difference to my other devices where the K3 app works that I can find is the launcher: drive mode dashboard 2 from thork racing.

I am confused: As far as I understood we are talking about K3 app. Why is there an influence which chrome version is inatalled?

I move this discussion to a separate topic.

Interesting that you could uninstall Chrome. Maybe Carpe Iter uses a different browser internally. Just to make sure, do you see any apps that can be updated in Google Play? Like Google Play Services, or any other Android internal apps?

I will check if we can improve this for the next version to get more information about the actual crash.

Parts of the Kurviger App use the Android Webview. The Android Webview is a special kind of browser. Depending on your Android version this internally either uses Google Chrome or Android Webview.

1 Like

To me it looks like the route planning part of K3 app is basically a copy of the web page.
Thus it heavily depends on the uesd browser.

Double-checked again today. Chrome had one more update, but nothing changed. I hope we can see more detail with the next beta, I will test and report.

Yes, you should be able to download the next beta update later today and it should show you more information on what is not working exactly.

Still the same Problem, but a new message

I attached a logcat log, just in case it might help
logcat.zip (31.7 KB)

Thanks for providing screenshots and logs.

The error Unexpected token ? is most probably related to an outdated WebView. I can reproduce this error using several years old browser versions.

Since Chrome is up to date on your device, could you check if you can install or update this app: https://play.google.com/store/apps/details?id=com.google.android.webview

If this doesn’t help, the only other option I see is to contact the manufacturer and ask them about the issue.

Hi There,

I have a Carpe Iter as well and I can confirm the same behaviour.
Even with the Webview Version installed from the link above.

The Carpe Iter has a modified Android Version 9 installed on it.

Can I provide any more info to solve the issue?

What could we ask the manufacturer to solve this?
Ask him to update the Webview component or to update the Android version?
The latter is probably very unlikely :wink:

But I would love to have the new Kurviger Version on my Carpe Iter!

Cheers,
David

Thanks for checking :slight_smile:.

Right now, we would need an updated Webview. Android 9 should be fine. I will send an email to Thork and see if we can find a solution for this.

1 Like

Okay, very good.
I will closely monitor this thread and can test anything that comes up.

Cheers,
David

1 Like

Thank you, ai stay tuned and test whatever you need

Thanks for your replies. So far we haven’t heard back from Carpe Iter / Thork Racing.

I still haven’t heard back from them. Maybe it makes sense if you as customers could ask them about it?

Done, hope that helps. In most cases they react within a day.

1 Like