GPS recording missing when app restarts


I have an issue with recording the driven track since 2…3 weeks. Normally, and this is what the instruction says, the track is being recorded until I delete it manually. This worked fine.

But know, if I use and reopen the app, my recorded track is gone.
I already reinstalled, tried beta, checked all options, but haven’t found the issue.

Can anybody help?

Thanks for the report, please provide more details.

What app version, Android version, device model…

Do you mean GPS recording?
Did you set the track (and panel) to be visible in GPS recording settings?

We cannot reproduce the report and I do not see anything strange in Google Play console.

Do you use blocker apps that limit Android / Google services?

Thanks for your fast reply.

Yes, I mean GPS recording. While driving it’s visible as a red line, as always. But when I close and reopen the app it’s gone.
Same when I upload a GPS track.

Samsung S20 FE (SM-G781B/DS)
Android 12 / OneUI 4.1
Kernel: 4.19.113-24328540
Kurviger 2 Pro ( 2.2.21)

I made a screen record. How can I share it with you?

You can attach the file or post it in a hosting website and attach the link.

Please find it here

1 Like

Thanks for the screen record.

Have other users seen anything in the GPS recording with Kurviger 2.2.21?

On my device

  • Kurviger 2.2.21
  • Android 8.0.0 (API 26)
  • samsung SM-A320FL

it works correct. The track only disappears when it is deleted with starting the respective action in the GPS recording dialog.

Are you sure that there is no blocker app on your device? Perhaps that could be the reason for the issues on your device, described by you.

I also tried with huge tracks of 1000+km on Android 13 and it seems to work correctly.

What could be a blocker? I don’t have anything in my phone that I have installed what could be the issue.

Before it worked for months…until it suddenly stopped … :-/


How do you test it?
Do you import a gpx track into GPS recording?

Do you have Kurviger 1 to make the same test?

Can you test with Cruiser?

(Kurviger uses Cruiser libraries)

Normally I record every track I make. I tried to test via GPS import and it didn’t work either, like in the screenrecord.

I also have Kurviger 1 Pro and there it works flawlessly. The issue is only with with Kurviger 2.

I checked the code and there were no changes to the GPS recording.

It is strange as it works for everyone else.
And Kurviger 2 had many months of beta testing.

Can you try on another device?

Seems to be only happening on my device and only with Kurviger 2, not 1.

Is there any possibility to clean delete and reinstall it with new permissions etc?
Normal reinstall did not solve the issue

If you are sure there is not any blocker apps that limit Android / Google services,
perhaps that device has enabled some Samsung setting that limit app functions.

Uninstall and re-install via Google Play performs clean installation of apps.

Clean install did not solve it. BUT I could manage the issue…

I had to delete cache and data in the android app menu. After that I did not loose the GPS tracks anymore


Hallo, die gefahrene Strecke wird bei mir in kurviger aufgezeichnet. Wenn ich die App schließe und wieder öffne, ist die aufgezeichnete Strecke gelöscht. Warum?
Hi, the driven route is shown in the map. After closing and reopening the app the driven route has been automatically deleted. Why?

There is a calculated route, which can be used in navigation (and changed in rerouting).

The last displayed calculated route is restored when app restarts.

Maybe it is related to this:

1 Like

Thanks, I will try that and report.