Getting always "Route not found" right at the beginning of route calculation

I sometimes get this kind of error when one of my waypoints is not at a reachable street. For example, my home-address is located on a walkway (no vehicles allowed) and I can never use the address in Kurviger, I need move the waypoint to the main street. This also happens with my office address which is legally reachable by vehicles, but when entering the address, the waypoint is set into the middle of the building and I get “route not found”. After moving the waypoint to the street in front of the building, it works.
My experience is: all waypoints as well as start and destination must be on a street legally reachable by your routing criteria.
I also got confused by this because other navigation apps always create a route and just get you as close as possible to your point if it is not reachable (e.g. to the street in front of a building instead of inside it or to the start of a walkway instead of along it).

Wenn es sich um Kartenfehler handeln sollte, zB Ihr Büro, wäre ein Routenbeispiel hilfreich. Dann könnten man es gegeben falls korrigieren oder Sie übernehmen das selber. :slightly_smiling_face:
If there are map errors, for example your office, a route example would be helpful. Then you could correct it if necessary or you could do it yourself.

1 Like

Sorry, I couldn’t reproduce the error anymore. Good to know it’s gone now. I’ve updated both maps and app several times so I can’t tell where the problem was.

1 Like

You can try Kurviger 1.13.5 (Beta) which has also improvements in online connection.

Sorry to say, but I have given up on te issue and bought the BMW Navigator VI for my BMW R 1200 GS which I am going to use in the future. It is less good than kurviger for sure, but on the other hand it is easier to use because of the control for it on the handlebar. Certainly I will give kurviger another go when I have to buy a new phone, since it is still the best app I have ever spend money for! Every motorcyclist should have and use it! It is very unfortunate it stopped working for me after 2-3 years of great experiences with it!

Can you share with us what exactly happened in your tests?

Did you factory reset the device which had the problem?

Did you test the app on a different device?

Did you try Kurviger 1.13.5 (Beta) which solved an internet issue for another user?

It has definitely something to do with the device (Samsung Galaxy S7). I did not factory reset ( I assume that would solve the issue at tis point), because I do not want to go through the procedure to set it up to the way it is at this moment, since that would cost me many, many hours I am not willing to spend. The app works fine on two different devices. I did not try the beta, but I might later. To be honest, I do not have high hopes it is an internet issue, since on that part everything works fine, and it did so for the last 2 years just until lately. I tried it with wifi, and it makes no difference. And if I configure kurviger to offline mode, it fails, either. I can download the maps just fine, I can go to and create routes, but as soon as I do that in the app on my mobile or imprt a successful one from, the route calculation fires up and fails immediately after that. No matter how short the route is, and it is definitely on the road, both start and target.

I have no idea what’s going on, and since none of the tips so far made any difference I assume no one else has, either.

I can only assume it has to do with an android update from Samsung, or another app or whatever. Ans as I said, the solution is probably a factory reset, but I am not willing to go through that process at this point in time. I do appreciate all the tips, help and support everybody tried to give!

If you uninstall and reinstall the app (so its cache is clean), do the online maps work?

That makes the case even more strange, as WiFi should work everywhere.

I have reinstalled the app multiple times, and I also tried the free version. What do you mean with online maps? The maps work fine everywhere, it is just as soon as some routing has to be done I get the error message.

The app contains offline and also online maps which need internet.

If the online maps work fine, then the routing server does not work.

Got it. OpenScienceMap doe snot work (no map shown at all), the other three do work, but same issue when I try to get a route calculated.

That is really really strange and I’m really sorry all this happened to you. Thanks for sticking with it and trying really hard before quitting, and providing so much constructive info anyway :slight_smile:

1 Like

My pleasure, I really love kurviger. And I tested the beta now, unfortunately no change. I do not think we will ever gonna solve this, without having a debug mode or logfiles saying anything meaningful, though.

Rest assured, once I have to switch to a new phone in the next couple of years I will give it another shot!

1 Like