Getting always "Route not found" right at the beginning of route calculation

[EN] I think I have found an issue with the route calculated by Kurviger
[DE] Ich glaube ich habe einen Fehler bei der Routenberechnung von Kurviger gefunden

I have been using for years now and I love it, must have app as a motorcyclist! But for a few weeks now I have the issue that whenever I select a destination (even something just 500m away) and the route calculation should start, I get “route not found”. Have tried all kinds of things, reinstall, change all kinds of settings (alternative routing on and off etc.), redownloaded maps etc., but no luck. I am using kurviger pro version 1.12.4 on a Samsung S7 ( SM-G930F, 1080x1920) with Android version 8.0.0 (API 26), Google location off (it does know and show where I am, though). Any idea how to fix this? Thanks a lot in advance!

Kurviger routing needs an internet connection.
Does the internet work in your device?
Can you open Kurviger website in device browser?

If the Kurviger website opens in device browser, please post a route sample and your route options.

Or could need offline routing (see documentation).

Hallo, wie kann Ihr Handy wissen wo Sie sind, wenn Sie Ihren Standort deaktivieren? :thinking:
Hello, how can your phone know where you are if you disable your location? :thinking:

Probably means that uses Android location service (instead of Google) in app location settings.

Alles klar, Danke. So ähnliche Gedanken hat ich auch gerade, als ich es mir nochmal durch den Kopf gehen ließ. :sweat_smile:
All right, thanks. I was having thoughts like that just as I was going over it again in my head. :sweat_smile:

1 Like

I removed that unneeded data from Info screen to avoid further confusion.

1 Like

Hi! I can open the webpage on the mobile browser (chrome), but I do get an error message web.generic_error. That may actually be the culprit. Does anybody know how to get rid of that error, before I continue to try fixing the other one?

Oh, and chrome tells me the website is not safe, that is odd. On my PC it is fine, but on my mobile the certificate is considered to be unsafe because the device could not verify it.

/Edit: Might be the virus scanner. If I only knew what name it had and how to access it. :confused:

Hm, not sure if I do have a virus scanenr installed, I might have deinstalled it again. However, I trid with firefox and it works just fine. Did set it as default browser, but kurviger pro still fails. I will try to import a route as suggested and report.

Importing a short route of 500m which I created shows the same error, the route is shown, though.

/Edit: To clarify, that does not solve the problem, kurviger still can’t follow the route and it is green instead of blue.

Hi! Anybody have any ideas left? I ran out. There is no virus scanner, I changed the default browser to firefox so the website works, but no change in the application. And remember, it used to work for years now, it just stopped working a couple of weeks ago.

With what network do you try?
Does it work on WiFi or mobile?

Another case is discussed here:

It does not work on either network, wifi or mobile.

Meine Idee wäre das Telefon auf Werkseinstellung zurückzusetzen. So können Sie bei Null beginnen und sehen ob der Fehler noch da ist.
My idea would be to reset the phone to factory defaults. This way you can start from zero and see if the error is still there.

That option I would like to choose as a last resort only, since it is like reinstalling Windoes just because one application does not work and it does not really fix the problem, but rather start from scratch and I will have to reestablish all settings/apps I have on that phone. However, since my problem does not seem to be a common one and there is no known fix, I probably will have to do that.

Thanks to everybody trying to help!

Es halt sehr schwierig den Fehler einzugrenzen, Internet funktioniert ja, Sie erreichen die Webseite über Firefox, ihr Netz ist nicht Salt. Was mir noch einfällt wäre die Berechtigungen für die App zu prüfen und könnten Sie die Route hier einstellen? Oder betrifft es generell alle Routen? Noch eine Möglichkeit wäre, falls Sie ein altes Handy zur Verfügung haben dieses mit dem Wlan zuverbinden und mit Ihrem Account zu aktivieren. Dann Kurviger Pro installieren und schauen ob das selbe Problem auftritt…
It is very difficult to isolate the error, the Internet works, you can reach the website via Firefox, your network is not Salt. What I can remember is to check the permissions for the app and could you set the route here? Or does it affect all routes in general? Another possibility would be, if you have an old mobile phone available, to connect it with the Wlan and activate it with your account. Then install Kurviger Pro and see if the same problem occurs…

1 Like

Or can uninstall and reinstall the app.

As I wrote before, I have uninstalled and reinstalled the app (and installed the free version, same problem there), I get the error with every route (even if the destination ist just 200m away) and the starting point does not matter, either. I even went to the Netherlands and tried it there to rule out the german map, same problem. I did check the permissions for the app, all are provided.

I am pretty sure it will work on a different device, since I can’t believe it is an account problem. But I will try today, just to make sure it is not that.

Mir ging es in dem Fall nicht darum ihr Google-Konto zu prüfen, sondern generell zu schauen ob nicht Ihr Handy einen Defekt hat. Sozusagen der letzte Strohhalm bevor nur noch ein Zurücksetzen bliebe…
In this case, I didn’t want to check your Google Account, but to check in general if your mobile phone has a defect. The last straw, so to speak, before there is only one more reset…

The phone works perfectly fine, apart from kurviger noit being able to calculate a route. Oh, and sygic does not show the traffic as it is supposed to do. Ah well, I think I will reset the phone and see what happens.

Do online maps work in the app?
(try new non-cached map areas)