Galaxy Note 9: GPS wandering

I created a route on the web at, then exported the file and am loading it with the Android Kurviger Pro app (v 1.8.1)

See the screen recording at

The route has a starting point in the north east and ends near my home location (Bukit Batok)

While still at home (and thus not in the open!!) I loaded this (unchanged) and then selected ‘route’ (start) expecting it to route me to the starting point.

It correctly speaks ‘route missed’ and ‘calculate route’ but but instead of recalculating, you can see the ‘current’ position slowly wandering northeast . (note I have not moved, I am still at home)

clicking the ‘crosshair’ button does not set it back to the correct location (at least not immediately, i had to press a few times)

Later, when I actually tried having Kurviger route me to my starting point wandering GPS location improved once I had open sky above me), but even though I selected ‘route / Start’ it wanted to route me to some point near the end of the shown route, not the start point. Note I did not select ‘nearest point’ . I behaved like that for a while while rode towards the starting point. Only when I did get nearly halfway to the starting point did it actually try and route me there. Methinks that maybe is confusing ‘route / Start’ with ‘route / nearest point’ ?

Can disable “Kalman filter” in “Settings | Map” (when indoors). It’s useful to reduce errors in GPS readings on navigation, obviously not much when indoors where GPS is not accurate.

Tried that. Now it sends me hundred and fifty Kilometers away when pressing the crosshairs. Turned Kalman back on, still the same. And then when I start the route, it jumps between the actual location and the one 150km north and keeps saying 'calculate route, continue for 150km, calculate route, in 2 km turn left, then …, calculate route, continue for 150km" in an endless loop. Even after I force stop the app this continues for minutes (I gather this is because I set the sound output to ‘notification’ which filled the buffer with hundreds of these

I had to restart my phone to get rid of the constant ‘rerouting’ messages that left.

I don’t have the GPS issues indoors with other map apps (Waze, Google Maps). There the crosshair button always finds my home just fine

Looks like something reports wrong GPS locations in the device then.

Do you try navigation outside where it should work or inside building?

Next version will introduce a location service with higher accuracy and better battery performance.

This was inside. Other apps (Maps, Waze) had no issues findung my correct location. with Kurviger so far it’s about 50:50 that it works indoors

Navigation works with GPS and naturally outside. :slightly_smiling_face:

Inside buildings location should work fine with e.g. Wi-Fi when browse the map.