Contradictory turn by turn instructions

I created and followed a round trip, but sometimes the voice instructions say turn left, but the map shows I have to turn right, and vice versa.
Then at another point, the map shows to go backwards and forwards repeatedly traversing a road for some reason.
As for re-routing when going off-route, I have found it loses its location and gives up on re-routing.
I have set to offline routing, and ticked rerouting as it says in the feedback.

Any ideas?

can you post a link to an example?
Might be due to same reason as in

Regards Markus


Please see also the related documentation.


I have also observed this behavior to occur for the case when you leave a route (with auto rerouting disabled) and - later - rejoin the same route again. Consider this example:

It contains start, end and a turn instruction in the middle, which asks you to turn left. If you follow this route from start to end all is good. If, however, you decide to leave the route and rejoin from, e.g. “Pfarrhofener Strasse” as shown in this screen shot:

you might still get the announcement to turn left even though this is wrong from the drivers perspective. This happens to me frequently. I have learned to live with this though as you can easily see the correct direction on the display anyways.


New turn instructions can be generated only after a rerouting.

If you resume a route even some meters before a turn instruction, then it’s still considered as valid.

We should keep in mind that human perception is completely different from what computer thinks.

1 Like

Location can only be lost if GPS has not good signal and does not report new locations.

Rerouting is performed periodically and depends on selected routing service.
Can be Kurviger with an offline backup (after loading its offline routing data).

I know. That’s fine. This is why I mentioned that I usually have re-routing turned off.

Yes, I understand that. The only thing you could do here is to ignore turn instructions in the vicinity of where the driver rejoins the route. But - as I said - not an issue for me as I can look at the display.

Thanks Tom.

No, it isn’t that I’ve deviated from the route - I’m just following and the voice and turn instruction says turn left, but I look at the map and it clearly shows turn right.

Next time it happens I’ll post a screenshot.

Voice guidance uses the turn instructions of the routing.

So also post the route itself, as everything happens there.

Not allowed to upload the route file because I’m a new user. You would have seen at Via Point 2 the map says turn right on to School Hill, but the turn instructions say turn left.
Is there another way to upload route files?

Also, missed the route later on and all it said was “missed route” and didn’t even try to reroute. Left me without any directions - scary.

Can I have my money back please?

You can post the Kurviger link from website (use Share button).

Rerouting needs to be enabled in navigation settings (it is by default).

And have internet connection or use offline routing.

This is the share URL:

Look at Point 1 near Calvert - this is where the directions contradict the map.

I do have rerouting enabled, but it still doesn’t do so.
Also at one point, it tried to take me on to a road that was marked “not suitable for motor vehicles”. I ignored it and it said “missed route” but didn’t offer any directions to get back on track.

Thanks for the example.

The reason is that the waypoint is placed exactly on the intersection.

Have you looked at the documentation posted above with the solution?
“We highly recommend to place waypoints on roads and not intersections”.

So rerouting works, but it produced incorrect route result?

Incorrect routing can have many reasons, explained again in documentation.
Do you have an example, so community can examine the map data there?

It’s important to understand that:

App is not responsible for the routing or turn instructions, those come directly from the server.
So app + website have the same routing and turn instructions.

If something is wrong in routing, you can test it in website and report here so we can fix it.

But I didn’t place the waypoint anywhere, I was just following the round trip created in the app.

The round trips are created in the server (not in the app).

So @boldtrn who handles the server can better check what happens there?

These situations should not happen too frequently, but yes this can happen when you create a round-trip that a waypoint is placed on an intersection and thus creates incorrect turn instructions.

We are always looking at improving the route calculation and this is one of the things I regularly tweak, but, there is no easy fix for this. This can happen.

I bet, that automatic rerouting was turned off.
Otherwise it would have said something like “recalculating …” and not “route missed”

1 Like