Cannot zoom or move map on Windows 10 2 in 1 in Chrome or Edge

I have a 2 in 1 Windows 10 device with touchscreen. I use Chrome.
i cannot move the map with my fingers, no swiping or zooming.
Same in Edge. In internet explorer the map moves and zooms but in a uncontrolled strange way.
On the iPhone it works. In Safari and Chrome.
Is it a setting in Chrome that prevents this?

Not that I am aware of. The website should work on Windows devices with touch screen using all common browsers.

When you open the website, are there any errors popping up in the top-right?

No errors.

In Edge I can move the map, but not zoom in or out using 2 fingers.

Unfortunately I am not really sure why this happens for you. By chance is anyone else encountering the same issue?

IIRC @SchlesiM has a Windows 10 touch device, but it’s working for you right?

Hello to everyone!

I have the following problem with the kurviger.de website.

I use Win10 on a tablet PC fitted with a touchscreen display.
That I have with me on tour for route planning.

Using the touchscreen function, the functions „scrolling up/down“ and „zoom in / zoom out“ by using the standard touchscreen gestus do not working in the map window. Using the stylus the same problem occures.

If I try the same thing with Google Maps or Bing Maps, it works fine.

Tested with Google Crome and Microsoft Edge.

To clarify, I filmed the problem - you can find the video here:
https://youtu.be/WLKIw4f4c08

Unfortunately, I have not found a setting in any browser that enables this.
Is there a solution now? Two posts from 2020 tell of the same problem

I would appreciate any pointers to resolve these issues.

Thanks & best regards
Peter


Hallo zusammen,

ich habe folgendes Problem mit der kurviger.de Website.

Ich verwende Win10 auf einem Tablet-PC mit Touchscreen den ich zur Routenplanung unterwegs mit dabei habe.

Bei der Verwendung der Touchscreen Funktion, sind im Kartenfenster die Funktionen Scrollen und vergrößern verkleinern nicht möglich. Ebenso bei Verwendung des Eingabestiftes.

Versuche ich das Gleiche zum Beispiel mit Google Maps oder Bing Maps o funktioniert das einwandfrei.

Getestet mit Google Crome und Microsoft Edge

Zur Verdeutlichung habe ich das Problem gefilmt – den Link findet ihr oben im englischen Teil des Postings

Leider habe ich bei keinem Browser eine Einstellung gefunden welche das ermöglicht.

Gibt es dazu mittlerweile eine Lösung? Zwei Postings von 2020 erzählen von dem gleichen Problem.

Schon mal vielen Dank
Peter

Thanks for the report. I just moved this to a question to the existing topic.

Not really, I actually thought this has resolved by itself :slight_smile:.

Something that is weird is that there are only very few complaints about this. So I am assuming it is working for most users with touchscreens but doesn’t work for a small number of users. Unfortunately I don’t have a Windows touch device available to test this.

Is this map working for you: Driving Directions - GraphHopper Maps

I think there exist a difference between 2in1 devices to tablet devices like an iPad.
Tablet devices have a different operating system to Win 10 and so is the reaction on the gestures.

By using an iPad the gestures act only in the map window frame.
By using a Win 10 touchscreen device like a tablet -PC the gestures act all over the whole browser window, as you can see in the video.

I have now tested your suggested GraphHopper maps and it worked proper with all gestures as it shoult be.

If you want, I can make a video to show it to you.

There must exist a difference how the gestures interacts with the different window frames!

I could find the relevant issue in the underlying map library. Unfortunately, I don’t see an easy fix for this right now, I hope this will be resolved with an update sooner than later.

I will check if there is something on our side that we can do to improve the situation.

Thanks a lot for your efforts – meanwhile I will look out for a tiny mouse.
It’s not really easy handling on tour and in the tent, but she will do the work until an update resolve the issue

I really like your support – kurviger.de is a really good choice
So please keep us up to date if you can improve something – I would like to test it for you guys.

1 Like

Finger gestures do not work for me on my Dell running Windows 10 pro touchscreen in Chromium based browsers. Kurviger in Firefox works fine. Grasshopper and Google maps works fine in Chrome, Edge, and Firefox.

I found a command line switch for Chromium based browsers. The command line addition --touch-events works on both Chrome and Edge. I created a shortcut on my desktop for Chrome and added the " --touch-events" to it and now Kurviger zooms correctly.
“C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” --touch-events

3 Likes

I am/was and found a command line switch which fixes the problem and might point to a solution.

Thanks for sharing, yes the issue is related touch events. It’s great that there is an option to work around this.

Right now: I know the source for the issue, but I cannot fix it as it comes from a library, where we have version conflict, I hope this can be resolved soon.

This issue should be fixed by now, I tested with a Windows touch device and it worked there. We recently updated our map library, which included a fix for this.

1 Like