Cannot Cross a Strait

I have been calculating a route which takes me into Northern Ireland, and I then want to cross from Northern Ireland into Scotland, but when I click on ‘Stranraer’, the route takes me all the way back down into Southern Ireland, across the Irish Sea into England, and back up to Scotland. Is there a reason for this?

Yes, I have removed the ‘avoid ferries’ option.

Please share your route example, so that we can reproduce your issue.
On the website “Export | share link”
Than post the resulting link - something like this:


Sure. This is what I mean –

You have activated all avoid options besides “avoid ferries” - this leads to the large detour.
Switching of all avoid option improves the route:

But probably this ferry should be used:

I think the problem might be the “private” access tags of


I am not sure, but from my point of view all “private” access settings should be changed to “customers” …


Dieses Problem hatten wir auch schon in anderen Häfen wie z.B. Oslo

Yeah, that works. I can untick those options, and the ferry crossing will appear, as I want it to.

But I want to avoid highways, major roads etc., so at some point, I need to reactivate those options, and when I do, the route is automatically recalculated, and the ferry crossing vanishes.

Please see screenshot.

These are the options that I had to select, to get what I needed. Leaving ‘avoid motorways’ unticked wasn’t an option.

Kannst du nicht für die Fährverbindung die Linien Navigation nutzen?


The Oslo ferry terminal should be fixed, I cleaned that a couple of weeks ago in OSM (was quite a bit of work let me tell you… :smiley: ), let me know if you find another problem in there

1 Like