Automatic offline route calculation does not work anymore

Hello, I installed the Kurviger app on my old Huawei Honor 9 and everything worked fine. :wink:

With my new Xiaomi RedmiNote 11, the automatic route recalculation does not work in offline mode during the drive. So if I leave the route, only the warning triangle and the old route are displayed, but it is not recalculated (recalculation is on, BRouter with segments and profiles are installed, BRouter is selected for offline routing etc. - it worked on the previous phone too).

When I manually select a different routing option (e.g. fast, curvy etc. etc.) it IS recalculated offline…but it should recalculate automaticly after 80m of leaving the track, so actually I have to switch the routing-options in the Routing/Options menue everytime I leave the Route.

Permission on media and background for BRouter is granted, all power options for Kurviger and BRouter are disabled.

Is that because of the new Xiaomi Phone, or because of the new app version from June 30th?

greetings Heiko

Thanks for the report.

However, I cannot reproduce it.

When selecting as routing service the “Kurviger (online) / BRouter (offline)”
and go away from the route without internet, BRouter calculates a new route.

Have you changed any app default settings in navigation?

How do you verify that route is calculated offline?
Does the toast meassage indicate BRouter?

To test offline you can set the phone into flight mode (air plane symbol)

Hi devemux86,

no, I only changed the routing service to Online/Offline and a color for the curvy route.

exactly, when I toggle the routing option the route is recalculated and the toast message says “BRouter…xx km”

The phone is in flightmode at this time.

For me it really looks like the checkbox for “recalculate route” does not work and the new route is only calculated, when I active toggle the routing profile.

Perhaps I’ll try to reinstall Kurviger tomorrow or use the last Version before 30.06.2022.


Ups, stop…I think you can forget it…I think it’s my fault.
I reinstalled BRouter and all profiles.

On my way back home from the office I testet it again…and now it works as it should.

I don’t know exactly why…but the last days I played around with the BRouter profiles (on the new smartphone) to avoid motorways and expressways for routing…and I think I destroyed anything in the profiles (avoid motorways, Vmax, car-eco…), so BRouter had a problem with the new route (because I tested the offline-routing on a expressway or dual carriageway (B14) on my way to the office).

But I don’t understand why there was a recalculation when I switched the profile…in that case I would expect, that BRouter still can’t find a route…because I’m on the same expressway as a second before. :wink:

Anyway…after reinstallation of BRouter now it works with automatic recalculation when I leave the route for 80m.



Please see the offline routing guide, it also contains info for how to change the BRouter profiles:

Navigation: offline rerouting happens when you leave the current route and trigger a rerouting (automatic or manual), skip the next waypoint, avoid road blocks, etc. while navigating without internet connection. The route is calculated from your current location to the existing route (based on navigation type). Only this small part of the route will be recalculated and merged with the previously planned route. This ensures, that the rest of the route remains as initially planned.”

Details about routing in navigation and the suggested change exist in this topic.

Changing manually route waypoints or parameters in navigation, the whole route is calculated.
BRouter may had problem calculating the small rerouting part (with your profile changes),
but the whole route calculation worked successfully.


I think, this could be the problem.
Anyway, my problem is solved, thanks for your time.