Any Updates on "Lost GPS Signal when display off"?

Hi guys,

just like others in the past I’m still having occasional issues when navigating with the Pro app and"display off" and GPS signal is lost (looks like), no turning instructions or distance to next waypoint anymore. What I find strange is, Google Maps works perfectly fine and Calimoto works fine on the same phone with no changes or additional apps to keep GPS active. What would be the difference between these apps? Why would my phone decide to keep GM and Cali active while killing Kurviger as soon as the display is turned off? Also, this problem seems to happen only every now and then, like when I kill kurviger via Settings > Apps and restart it, it sometimes keeps working in the background, sometimes not. Also, it does sometimes help to have Google Maps car-mode active in the background that would sustain an active GPS Signal.

I did the compulsory steps already, like turn off battery optimization, deleted cache and userdata.

Is there any update on this topic, like “hey, just tick/untick that option” or “set those parameters to these values” to make it work?

Pixel 4 XL, Android 10 (QQ3A.200605.001)
Kurviger Pro 1.12.4

Screenshot shows result of a tour I did. Display was only on in the red circles, and off in between

No one can know how other apps work or how each device behaves with its Android version.

What is certain is that Kurviger was implemented with all the official rules for background use.

You can select and test a different location provider in “Settings | Location | Location service”.

Please check the documentation and next website to make Kurviger not battery optimized:

Brilliant! In other words: no idea, no solution, the error must be somewhere else, but thanks for the money.
Could have spend the 10 bucks in another app which actually works and is usable for everyone, like other developers (Calimoto) who seem to “know how it works”… Good stuff guys!

This is a Civilized Place for Public Discussion.

There is no other app that offers so much at such a low price.
With 1 time purchase and not expensive in-app subscriptions.

The problem is widespread in Android world and apps are usually not responsible.
Solution is inside each phone’s settings to make the app not battery optimized:

3 Likes

I know that there are not many other apps around with that functional frame and all maps included and stuff, and sorry for ranting… but please understand that its kind of… cumbersome to read several other topics with the same issue, hoping for anything that helps and try everything that has been suggested already, and then coming up with my own topic in this forum to ask for an update - and the only answer is the standard-stuff again: check battery management, check stand-by, check android/google as navigation source, etc etc… I did that, I even tried stuff not even mentioned here. Its just not working as it should. So, all that nice functions and maps with 1 time purchase, nice, but I cannot use it. I cannot use the app which I paid money for, only to get the answer: sorry, but no idea.

Anyway, with that of my chest, is there anything I could do to support the process? Can I somehow generate logfiles within/outside the app to give you an idea whats going on when screen is off?

Hallo DionysiusRR hast Du die Vorschläge ausprobiert? Bei meinem Honor waren es die Energiesparmaßnahmen des Herstellers die zu ähnlichen Problemen führten… Zu dem von Dir angesprochenen Calimoto, wenn man sich die Bewertungen bei Google Play durch liest, tritt auch dort das oder ähnliche Probleme auf. Ich habe Dir mal 2 Bilder hochgeladen, allerdings in Deutsch, vielleicht hilft Dir das.

Hello DionysiusRR did you try the suggestions? With my Honor it was the energy saving measures of the manufacturer that led to similar problems… If you read the reviews on Google Play for the Calimoto you mentioned, you will also encounter this or similar problems there. I have uploaded 2 pictures, but in German, maybe this will help you.

Can you tell us what settings you did exactly to turn battery optimization off.
On many devices there is more than one setting necessary, to protect the app from being killed by the “battery optimization”

I don’t know if it might be related, but what settings have you for location?
settings | location | location service

Edit:
Some of your actions indicate that you think it is the apps fault like:

  • kill kurviger via Settings > Apps and restart
  • deleted cache and userdata

Try thinking, that it is the OS’s fault.
Then try searching for hints, how to turn battery optimization off on your device.

Moin, und danke für deine Antwort.

Ja die Vorschläge habe ich probiert. Da ich das Pixel habe, fehlen die hesteller-spezifischen Batterie-Management-Optionen, nur das rohe Betriebssystem ist installiert, d.h. die Optionen wie in deinem Screenshot habe ich so nicht. Ich habe in den Einstellungen -> Apps -> Kurviger -> Batterie die Optimierung deaktiviert. Ich wollte im ursprünglichen Post auch ein Screenshot davon hochladen, aber man durfte nur ein Bild hochladen. Also, ja, Batterie-Management habe ich deaktiviert für Kurviger, jedoch keine Änderung im Verhalten.

Wegen Calimoto: Ja, mag sein dass andere Nutzer ähnliche Probleme auch mit dieser App haben. Worum es mir aber geht ist, Calimoto funktioniert mit Bildschirm aus auf meinem Handy. Google Maps funktioniert mit Bildschirm aus auf meinem Handy. Kurviger nicht. Von daher scheint es wohl nicht am Handy zu liegen, oder am Standort-Service.

Hi, thanks for your reply.

So what I did outside the App:

  • Deactivate battery management for kurviger-app in Settings -> Apps & Notifications -> “All Apps” -> Kurviger Pro -> Battery -> Battery Optimization set to ‘Not optimized’
  • Delete Cache
  • Delete User data
  • Force shutdown (helped sometimes, but then lost GPS the next day again)
  • Have Google Maps Car Mode running in background

Inside the App:

  • De/activate Kalman filter
  • Tried location Service “Google” and “Android”
  • De/activate track recording
  • GPS Filter
    • 0s / 3s / 10s time intervall
    • 10m / 50m / 100m minimum distance
    • off / 2kph / 5kph minimum velocity

I turned on developer options in Android to completely turn off doze mode, but couldn’t find the option. Do you have an idea?