Kurviger.de | Application | Blog | Frequently Asked Questions (FAQ) | Legal Notice | Privacy Policy

Abbiegehinweise / Roadbook

Vor Kurzem ist das Format der .csv-Datei für die Abbiegehinweise (roadbook) wohl geändert worden. Eine im Prinzip vernünftige Änderung ist der Export im UTF-8 BOM - Format! Dadurch ist es beim Import in Excel nicht mehr erforderlich den Dateiursprung mühsam auf “65001: Unicode (UTF-8)” einzustellen.
Allerdings werden durch diese Änderung (oder im Zuge der Änderung) die Symbole in der .csv-Datei nicht mehr differenziert dargestellt (im Gegensatz zur Darstellung in kurviger.de):

Mein Excel-Macro selektiert auf Basis des Symbols Start, Ziel und Wegpunkte und funktioniert somit nun natürlich nicht mehr. Bei der Gelegenheit: vielleicht wäre die optionale Erstellung des .csv-Files nur mit Start, Ziel und Wegpunkten sinnvoll?

1 Like

Außerdem: Bei umbenannten Wegpunkten wird in der .csv-Datei leider nicht der umbenannte Name angezeigt :unamused:.
Anmerkung: In den Abbiegehinweisen und im Roadbook-Fenster werden die umbenannten Namen angezeigt :+1:.

Vielen Dank für den Hinweis, beim CSV Export hat sich wohl ein Fehler eingeschlichen, dieser sollte aber schnell behoben sein.

Das Problem sollte mittlerweile behoben sein, könnt ihr das mal bei Gelegenheit prüfen ob jetzt alles passt?

1 Like

Das Problem ist gelöst!
Allerdings muss jetzt wieder beim Excel-Import der Dateiursprung auf “65001: Unicode (UTF-8)” eingestellt werden. Vielleicht geht ja doch ein “UTF-8 BOM”-Export aus kurviger.de heraus?
Ist aber nicht sehr wichtig!

Also ich hab jetzt nochmal ein bisschen was umgestellt, magst dus nochmal probieren? Ich hab mal versucht das BOM hinzuzufügen. Bei mir am Rechner hat er davor auch immer schon automatisch utf-8 genommen, geht es bei dir jetzt?

2 Likes

Funktioniert jetzt :+1:. Danke für schnelle Erledigung!

1 Like

:+1: Funktioniert nun einwandfrei! Vielen Dank, Robin. :clap:

2 Likes

Wie vor 3 Stunden geschrieben, funktioniert der Excel-Import jetzt einwandfrei, der Characterset stimmt, die Symbole kommen richtig an. Nochmal dankeschön für die schnelle Lösung.

Aber - jetzt hab’ ich doch noch eine Ungereimtheit entdeckt. Und zwar werden einige Strecken mit 0 km und 0 min ausgewiesen, wobei die Distanz in die nachfolgende Teilstrecke einfließt - so dass die Gesamtstrecke stimmt. Sorry dass ich Dir Arbeit kreiere …

Hier ein paar screenshots:

Und die entsprechenden Files dazu:
Kaltern_r.kurviger (55.9 KB)
Kaltern_r.zip (36.1 KB)

Ahh, vielen Dank! Ja da war in der Tat ein Fehler. Dadurch haben sich die Distanzen verschoben, jetzt sollte aber alles wieder passen. Könntest dus dir bei Gelegenheit nochmal anschauen?

1 Like

Habe es am Beispiel von @zaphod_42 ausprobiert. Konnte keinen Fehler finden. Sowohl Wegpunktnamen und Werte für Entfernungen und Zeiten stimmen jetzt sowohl in Abbiegehinweisliste, Roadbook, CSV-Datei und Wegpunkt-Widget überein :+1:. Symbole in Roadbook und CSV-Datei stimmen überein :+1:.

Habe die Route sowohl mit Shapingpoints (Beispiel zaphod_42) als auch nur mit Viapoints (Shapingpoints zu Viapoints umgewandelt) getestet.

Danke Robin für die rasche Überarbeitung.

Übrigens finde ich es für die Erstellung eines Roadbooks sehr gut, dass in der Webseite in der Abbiegehinweisliste auch die Shaping-Points mit aufgelistet sind. Kann bei der Erstellung des Roadbooks z.B. mit Excel sehr hilfreich sein.

Danke Wolfgang für das Beispiel. Das enthält doch so einige Feinheiten über die man stolpern kann. Beispiele:

  • Direkt aufeinander folgende Wegpunkte ohne Abbiegehinweis dazwischen
  • Wegpunkt im Kreisverkehr

Der Wegpunkt 10 (Wegpunkt im Kreisverkehr) führt zu einem Verhalten, das man auf den ersten Blick als abnormal einschätzen könnte:

Wegpunkt 10 (Viapoint) mit Info-Bubble:

grafik

Beim Wegpunkt erfolgt ein Abbiegehinweis zur Ausfahrt aus dem Kreisverkehr:

grafik

Dies führt zu folgenden Anzeigen in der Abbiegeliste und im Roadbook bzw. in CSV-Datei:

grafik

Hierbei könnte man meinen, dass irgend etwas schiefgelaufen sein könnte. Dies ist jedoch nicht der Fall. Da der Namenshinweis und der Abbiegehinweis für die selbe Position erfolgt führt dies in der Tabelle beim Abbiegehinweis zu einer Entfernung von 0 zwischen Wegpunkt 10 und Abbiegehinweis. Somit ist alles bei der Routenberechnung und in den Tabellen korrekt :slightly_smiling_face:.

Eines ist nicht korrekt, und da ist das Problem vor dem Rechner :wink:! Es wurde vom Grundsatz abgewichen, dass Wegpunkte nicht auf Kreuzungen, Abzweigungen, Kreisverkehre gesetzt werden sollen!
Wenn dieser Grundsatz eingehalten wird, kommt es nicht zu obigen (evtl. als abnormal eingeschätzten) Anzeigen in den Tabellen.

Deshalb noch mal Danke an euch beide. Sowohl für das tricky Beispiel als auch für die Korrektur im Programm.

2 Likes

Vielen Dank fürs Testen und dein Feedback @WalterG.

Ja Wegpunkte im Kreisverkehr sind ein Problem-Thema, das geht technisch leider nicht anders, daher stimmt auch die Ausfahrts-Nummer nicht.

Danke Robin für die schnelle Lösung,
danke Walter fürs Testen!
Ich war unterwegs und dadurch nicht in der Lage die Tests durchzuführen. Aber Walter ist ja dankenswerterweise eingesprungen. Und das mit dem Kreisverkehr als NoGo für Wegpunkte habe ich nicht gewusst - Kreuzungen und Abzweigungen waren bisher meine NoGos. Aber ich habe ja eine steile Lernkurve! :wink:

Nogo ist auch ein bisschen übertrieben, aber ist halt eine vermeidbare Fehlerquelle :slight_smile:

1 Like